<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>Community members question School Board candidates during Thursday event - My Edmonds News</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://myedmondsnews.com/xmlrpc.php" />
    <meta property="og:image" content="https://i1.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg?fit=583%2C386" />
<!-- This site is optimized with the Yoast SEO plugin v5.0.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Community members question School Board candidates during Thursday event - My Edmonds News" />
<meta property="og:description" content="Aloha Cafe in Lynnwood was filled with interested community members on Thursday evening to hear what School Board candidates had to say during a candidate coffee round-table. Three candidates (Deborah Kilgore, Cindy Sackett and Cathy Baylor) are running on the Aug. 1 primary ballot for Position 4 on the Edmonds School District 15 board now &hellip;" />
<meta property="og:url" content="http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/" />
<meta property="og:site_name" content="My Edmonds News" />
<meta property="article:section" content="Education" />
<meta property="article:published_time" content="2017-07-07T17:22:05-07:00" />
<meta property="article:modified_time" content="2017-07-07T19:42:51-07:00" />
<meta property="og:updated_time" content="2017-07-07T19:42:51-07:00" />
<meta property="og:image" content="http://myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg" />
<meta property="og:image:width" content="583" />
<meta property="og:image:height" content="386" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Aloha Cafe in Lynnwood was filled with interested community members on Thursday evening to hear what School Board candidates had to say during a candidate coffee round-table. Three candidates (Deborah Kilgore, Cindy Sackett and Cathy Baylor) are running on the Aug. 1 primary ballot for Position 4 on the Edmonds School District 15 board now [&hellip;]" />
<meta name="twitter:title" content="Community members question School Board candidates during Thursday event - My Edmonds News" />
<meta name="twitter:site" content="@myedmondsnews" />
<meta name="twitter:image" content="https://i1.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg?fit=583%2C386" />
<meta name="twitter:creator" content="@myedmondsnews" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="My Edmonds News &raquo; Feed" href="http://myedmondsnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="My Edmonds News &raquo; Comments Feed" href="http://myedmondsnews.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="My Edmonds News &raquo; iCal Feed" href="http://myedmondsnews.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="My Edmonds News &raquo; Community members question School Board candidates during Thursday event Comments Feed" href="http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/myedmondsnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6938b1e34e881dc1f3c1c517189a0b1e"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://myedmondsnews.com/wp-includes/css/dashicons.min.css?ver=6938b1e34e881dc1f3c1c517189a0b1e' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='http://myedmondsnews.com/wp-content/plugins/wunderground/assets/css/wunderground.css?ver=2.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='bwp-rc-css'  href='http://myedmondsnews.com/wp-content/plugins/bwp-recent-comments/css/bwp-recent-comments.css?ver=1.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://myedmondsnews.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.3.1.5' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='wpfront-notification-bar-css'  href='http://myedmondsnews.com/wp-content/plugins/wpfront-notification-bar/css/wpfront-notification-bar.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C600%2C700%7CRoboto+Condensed%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic&#038;ver=3.4' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='http://myedmondsnews.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://myedmondsnews.com/wp-content/themes/Newsmag/style.css?ver=3.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://myedmondsnews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.1' type='text/css' media='all' />
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/wp-a11y.min.js?ver=6938b1e34e881dc1f3c1c517189a0b1e'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"a180ff6b87","ajaxurl":"http:\/\/myedmondsnews.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/wunderground/assets/js/widget.min.js?ver=2.1.3'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/bwp-recent-comments/js/bwp-rc-ajax.js?ver=1.2.2'></script>
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init.js?ver=6938b1e34e881dc1f3c1c517189a0b1e'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.3.1.5'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.3.1.5'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/wpfront-notification-bar/jquery-plugins/jquery.c.js?ver=1.4.0'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/wpfront-notification-bar/js/wpfront-notification-bar.js?ver=1.7'></script>
<link rel='https://api.w.org/' href='http://myedmondsnews.com/wp-json/' />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://myedmondsnews.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://myedmondsnews.com/?p=159146' />
<link rel="alternate" type="application/json+oembed" href="http://myedmondsnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmyedmondsnews.com%2F2017%2F07%2Fcommunity-members-question-school-board-candidates-thursday-event%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://myedmondsnews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmyedmondsnews.com%2F2017%2F07%2Fcommunity-members-question-school-board-candidates-thursday-event%2F&#038;format=xml" />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://myedmondsnews.com/xmlrpc2.php?rsd" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//myedmondsnews.com/?wordfence_logHuman=1&hid=6F09BD32DDC7600323BD0F61EB11FDD3');
</script><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://myedmondsnews.com"><link rel="https://theeventscalendar.com" href="http://myedmondsnews.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://myedmondsnews.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><script type="text/javascript">
	var bwp_ajax_url = 'http://myedmondsnews.com/';
</script>
<meta name="generator" content="Powered by Slider Revolution 5.3.1.5 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />

<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":251},{"limitBottom":1023,"sidebarWidth":339}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/myedmondsnews.com\/wp-admin\/admin-ajax.php?td_theme_name=Newsmag&v=3.4";
var td_get_template_directory_uri="http:\/\/myedmondsnews.com\/wp-content\/themes\/Newsmag";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="3";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#325076";
var tds_smart_sidebar="enabled";
var tdThemeName="Newsmag";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-16486256-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-159146 single-format-standard tribe-no-js tribe-theme-Newsmag community-members-question-school-board-candidates-thursday-event global-block-template-1 wpb-js-composer js-comp-ver-5.1.1 vc_responsive td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/myedmondsnews" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/myedmondsnews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-body-nav-example-container"><ul id="menu-body-nav-example" class="td-mobile-main-menu"><li id="menu-item-65553" class="cgreen1 menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-65553"><a href="http://myedmondsnews.com/">Home</a></li>
<li id="menu-item-65571" class="cgreen2 menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-65571"><a href="http://myedmondsnews.com/about-2/">About<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-65572" class="cblue menu-item menu-item-type-post_type menu-item-object-page menu-item-65572"><a href="http://myedmondsnews.com/about-2/contact/">Contact</a></li>
</ul>
</li>
<li id="menu-item-115133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-115133"><a href="http://myedmondsnews.com/advertise-2/">Advertise<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-102255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102255"><a href="http://myedmondsnews.com/advertise/advertising-options-capture-readers-attention/">Advertising options that capture readers&#8217; attention</a></li>
	<li id="menu-item-65704" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65704"><a href="http://myedmondsnews.com/advertise/ad-payments/">Ad Payments</a></li>
</ul>
</li>
<li id="menu-item-149515" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149515"><a href="http://myedmondsnews.com/my-edmonds-news-sponsors/">My Edmonds News sponsors</a></li>
<li id="menu-item-107782" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107782"><a href="http://myedmondsnews.com/support-us-with-a-subscription/">Subscribe</a></li>
<li id="menu-item-132199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-132199"><a href="http://myedmondsnews.com/text-alerts/">Text Alerts</a></li>
<li id="menu-item-113880" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113880"><a href="http://www.cafepress.com/+my-edmonds-news+gifts">MEN Merchandise</a></li>
<li id="menu-item-113228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113228"><a href="http://myedmondsnews.enotices.org/">Public Notices</a></li>
<li id="menu-item-125281" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-125281"><a href="#">Categories<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-67009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67009"><a href="http://myedmondsnews.com/category/edmonds-entertainment/books/">Books</a></li>
	<li id="menu-item-65836" class="cgreen2 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65836"><a href="http://myedmondsnews.com/category/news/edmonds-business/">Business</a></li>
	<li id="menu-item-65830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65830"><a href="http://myedmondsnews.com/category/news/edmonds-politics/">Politics</a></li>
	<li id="menu-item-65831" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65831"><a href="http://myedmondsnews.com/category/news/health-and-fitness/">Health</a></li>
	<li id="menu-item-135395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135395"><a href="http://myedmondsnews.com/category/government/">Government</a></li>
	<li id="menu-item-65840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65840"><a href="http://myedmondsnews.com/category/news/military-news/">Military News</a></li>
	<li id="menu-item-65832" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65832"><a href="http://myedmondsnews.com/category/news/pets/">Pets</a></li>
	<li id="menu-item-65577" class="cblue menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65577"><a href="http://myedmondsnews.com/category/news/public-safety/">Public Safety</a></li>
	<li id="menu-item-107226" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-107226"><a href="http://myedmondsnews.com/category/news/edmonds-schools/">Education</a></li>
	<li id="menu-item-65833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65833"><a href="http://myedmondsnews.com/category/news/edmonds-traffic/">Traffic</a></li>
	<li id="menu-item-65834" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65834"><a href="http://myedmondsnews.com/category/news/edmonds-weather/">Weather</a></li>
	<li id="menu-item-65574" class="cblue menu-item menu-item-type-post_type menu-item-object-page menu-item-65574"><a href="http://myedmondsnews.com/edmonds-happy-hour/">Edmonds Happy Hour</a></li>
	<li id="menu-item-67012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67012"><a href="http://myedmondsnews.com/category/edmonds-entertainment/the-arts/">The Arts</a></li>
	<li id="menu-item-146106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-146106"><a href="http://myedmondsnews.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li id="menu-item-66982" class="cblue menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-66982"><a href="http://myedmondsnews.com/category/recreation/">Sports<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-73798" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73798"><a href="http://soundlivesportsnetwork.com/">Sound Live Sports Network</a></li>
</ul>
</li>
<li id="menu-item-65841" class="cgreen1 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65841"><a title="Edmonds Kind of Play" href="http://myedmondsnews.com/category/columns/">Columns</a></li>
<li id="menu-item-112423" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112423"><a href="http://myedmondsnews.com/w-video-studio/">W Video Studio</a></li>
<li id="menu-item-65575" class="cgreen1 menu-item menu-item-type-post_type menu-item-object-page menu-item-65575"><a href="http://myedmondsnews.com/trafficferry/">Traffic/Ferry</a></li>
<li id="menu-item-67877" class="cgreen1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-67877"><a href="http://myedmondsnews.com/events/">Events<i class="td-icon-menu-right td-element-after"></i></a>
<ul  class="sub-menu">
	<li id="menu-item-67878" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-67878"><a href="http://myedmondsnews.com/events/community/add">Submit Event</a></li>
</ul>
</li>
<li id="menu-item-67017" class="cgreen2 menu-item menu-item-type-post_type menu-item-object-page menu-item-67017"><a href="http://myedmondsnews.com/edmonds-links/">Links</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="http://myedmondsnews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap">
    
        <div class="td-outer-container">
        
            <!--
Header style 1
-->

<div class="td-header-container td-header-wrap td-header-style-1">
    <div class="td-header-row td-header-top-menu">
        
    <div class="td-top-bar-container top-bar-style-1">
        <div class="td-header-sp-top-menu">

            <div class="td_data_time">
            <div >

                Friday, July 7, 2017
            </div>
        </div>
    <div class="menu-top-container"><ul id="menu-top-nav-example" class="top-header-menu"><li id="menu-item-65550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-65550"><a href="http://myneighbornewsnetwork.com/">My Neighborhood News Network</a></li>
<li id="menu-item-65579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home td-menu-item td-normal-menu menu-item-65579"><a href="http://myedmondsnews.com">My Edmonds News</a></li>
<li id="menu-item-65580" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-65580"><a href="http://mltnews.com">MLTnews</a></li>
<li id="menu-item-65581" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-65581"><a href="http://lynnwoodtoday.com">Lynnwood Today</a></li>
</ul></div></div>            <div class="td-header-sp-top-widget">
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/myedmondsnews" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/myedmondsnews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>
        </div>

<!-- LOGIN MODAL -->
    </div>

    <div class="td-header-row td-header-header">
        <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="http://myedmondsnews.com/">
                <img src="http://myedmondsnews.com/wp-content/uploads/2016/02/My-Edmonds-News-Logo-Stacked-013116v2.jpg" alt=""/>
                <span class="td-visual-hidden">My Edmonds News</span>
            </a>
                </div>
        <div class="td-header-sp-rec">
            
<div class="td-header-ad-wrap  td-ad-m td-ad-tp td-ad-p">
    <div class="td-a-rec td-a-rec-id-header  "><script type="text/javascript">broadstreet.zone(1449, {responsive: true});</script></div>

</div>        </div>
    </div>

    <div class="td-header-menu-wrap">
        <div class="td-header-row td-header-border td-header-main-menu">
            <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
                <a class="td-main-logo" href="http://myedmondsnews.com/">
            <img src="http://myedmondsnews.com/wp-content/uploads/2016/02/My-Edmonds-News-Logo-Stacked-013116v2.jpg" alt=""/>
        </a>
        </div>
    <div class="menu-body-nav-example-container"><ul id="menu-body-nav-example-1" class="sf-menu"><li class="cgreen1 menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-65553"><a href="http://myedmondsnews.com/">Home</a></li>
<li class="cgreen2 menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-65571"><a href="http://myedmondsnews.com/about-2/">About</a>
<ul  class="sub-menu">
	<li class="cblue menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-65572"><a href="http://myedmondsnews.com/about-2/contact/">Contact</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-115133"><a href="http://myedmondsnews.com/advertise-2/">Advertise</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-102255"><a href="http://myedmondsnews.com/advertise/advertising-options-capture-readers-attention/">Advertising options that capture readers&#8217; attention</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-65704"><a href="http://myedmondsnews.com/advertise/ad-payments/">Ad Payments</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-149515"><a href="http://myedmondsnews.com/my-edmonds-news-sponsors/">My Edmonds News sponsors</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-107782"><a href="http://myedmondsnews.com/support-us-with-a-subscription/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-132199"><a href="http://myedmondsnews.com/text-alerts/">Text Alerts</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-113880"><a href="http://www.cafepress.com/+my-edmonds-news+gifts">MEN Merchandise</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-113228"><a href="http://myedmondsnews.enotices.org/">Public Notices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-125281"><a href="#">Categories</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-67009"><a href="http://myedmondsnews.com/category/edmonds-entertainment/books/">Books</a></li>
	<li class="cgreen2 menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65836"><a href="http://myedmondsnews.com/category/news/edmonds-business/">Business</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65830"><a href="http://myedmondsnews.com/category/news/edmonds-politics/">Politics</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65831"><a href="http://myedmondsnews.com/category/news/health-and-fitness/">Health</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-135395"><a href="http://myedmondsnews.com/category/government/">Government</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65840"><a href="http://myedmondsnews.com/category/news/military-news/">Military News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65832"><a href="http://myedmondsnews.com/category/news/pets/">Pets</a></li>
	<li class="cblue menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65577"><a href="http://myedmondsnews.com/category/news/public-safety/">Public Safety</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-107226"><a href="http://myedmondsnews.com/category/news/edmonds-schools/">Education</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65833"><a href="http://myedmondsnews.com/category/news/edmonds-traffic/">Traffic</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65834"><a href="http://myedmondsnews.com/category/news/edmonds-weather/">Weather</a></li>
	<li class="cblue menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-65574"><a href="http://myedmondsnews.com/edmonds-happy-hour/">Edmonds Happy Hour</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-67012"><a href="http://myedmondsnews.com/category/edmonds-entertainment/the-arts/">The Arts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-146106"><a href="http://myedmondsnews.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li class="cblue menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-66982"><a href="http://myedmondsnews.com/category/recreation/">Sports</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-73798"><a href="http://soundlivesportsnetwork.com/">Sound Live Sports Network</a></li>
</ul>
</li>
<li class="cgreen1 menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-65841"><a title="Edmonds Kind of Play" href="http://myedmondsnews.com/category/columns/">Columns</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-112423"><a href="http://myedmondsnews.com/w-video-studio/">W Video Studio</a></li>
<li class="cgreen1 menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-65575"><a href="http://myedmondsnews.com/trafficferry/">Traffic/Ferry</a></li>
<li class="cgreen1 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-67877"><a href="http://myedmondsnews.com/events/">Events</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-67878"><a href="http://myedmondsnews.com/events/community/add">Submit Event</a></li>
</ul>
</li>
<li class="cgreen2 menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-67017"><a href="http://myedmondsnews.com/edmonds-links/">Links</a></li>
</ul></div></div>

<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="http://myedmondsnews.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>        </div>
    </div>
</div>
    <div class="td-container td-post-template-default">
        <div class="td-container-border">
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    

    <article id="post-159146" class="post-159146 post type-post status-publish format-standard has-post-thumbnail hentry category-edmonds-schools category-election-2017" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header td-pb-padding-side">
            
            <ul class="td-category"><li class="entry-category"><a  href="http://myedmondsnews.com/category/news/">News</a></li><li class="entry-category"><a  href="http://myedmondsnews.com/category/news/edmonds-schools/">Education</a></li><li class="entry-category"><a  href="http://myedmondsnews.com/category/election-2017/">Election 2017</a></li></ul>
            <header>
                <h1 class="entry-title">Community members question School Board candidates during Thursday event</h1>

                

                <div class="meta-info">

                                        <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2017-07-07T17:22:05+00:00" >July 7, 2017</time></span>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-159146">97</span></div>                    <div class="td-post-comments"><a href="http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/#respond"><i class="td-icon-comments"></i>0</a></div>                </div>
            </header>


        </div>

        

        <div class="td-post-content td-pb-padding-side">

        
        <figure id="attachment_159148" style="width: 583px" class="wp-caption alignnone"><a href="https://i1.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg"><img class="wp-image-159148 size-full" src="https://i1.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg?resize=583%2C386" alt="" srcset="https://i1.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg?w=583 583w, https://i1.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg?resize=300%2C199 300w" sizes="(max-width: 583px) 100vw, 583px" data-recalc-dims="1" /></a><figcaption class="wp-caption-text">moderator Teresa Wippel asks candidates (left to right) Deborah Kilgore, Cathy Baylor and Cindy Sackett to introduce themselves.</figcaption></figure>
<p>Aloha Cafe in Lynnwood was filled with interested community members on Thursday evening to hear what School Board candidates had to say during a candidate coffee round-table.</p>
<p>Three candidates (Deborah Kilgore, Cindy Sackett and Cathy Baylor) are running on the Aug. 1 primary ballot for Position 4 on the Edmonds School District 15 board now held by Board Member Susan Phillips, who is not seeking reelection. The top two vote-getters in the primary qualify for the Nov. 7 general-election ballot.</p>
<p><em>My Edmonds News, MLTnews </em>and<em> Lynnwood Today</em> sponsored the event. Following brief one-minute introductions for each candidate, community members asked the candidates questions about topics they were most concerned about.</p>
<p>Below are some of the questions asked by voters and answers provided by the candidates. Answers have been provided in the order they were presented during the event:</p>
<p><em>Q: Each candidate may have one minute to introduce themselves.</em></p>
<p>Kilgore: I am a longtime volunteer at Lynnwood Elementary, I have three children in the Edmonds School District. Two are at Lynnwood High School and one is still at Lynnwood Elementary. I have been a PTO president for three of those years I’ve been involved at the elementary school. I also have a profession in education. I have a PhD in Education from Texas A&amp;M and I work at the University of Washington as an educational researcher where we look at how engineering students learn and how to design the best kinds of learning experiences for them. I think all of this experience, including having kids in the school, sort of brings me to this place where I think this is the right time and the right place for me to get involved in the school board.</p>
<p>Baylor: I have lived in the school district for 49 years. I went to school here, I graduated from Lynnwood High School and I raised my kids here. They went to the Terrace Park School and the IB program over at Edmonds-Woodway High School. I have a degree from the University of Washington in Education, Music and Spanish, lots of different things I like to study. And I have been working as a volunteer in the school district and education in the community for the last 30 years. I have been the president of five different educational organizations and I work now as a piano teacher, where I collaborate with a lot of school district employees. I love working with education. Multicultural education especially is really important to me. It’s been a passion all my life, and I’ve always felt education is the one thing that can solve all our problems.</p>
<p>Sackett: First and foremost, I’m a mom to two teenagers, a 16- and 18-year-old. I’m a wife. I’m a daughter, sister and an advocate for education. I have worked in the education system in Edmonds. I have lived here for 14 years. I’ve volunteered, I’ve been PTA president, I’ve been PTA treasurer, I’ve been the one cleaning up at the end of every event. I really have a passion around making sure all of our kids succeed and are given the opportunities to do what engages them. I currently have a role where I work for a nonprofit graduating a quarter of a million students who are career/college ready and I hope to bring some of that expertise to the school board, as well as my finance background. I’ve been working with multi-million dollar budgets for over 20 years.</p>
<p><em>Q: How much of a role do you see for project-based teaching?</em></p>
<p>Kilgore: I think it is an effective way for students to get, and educators to get, what I call significant learning, which is learning that is deep, long-lasting, authentic. When they can work on a project that is sort of real-world, it sticks. It sticks with them. I’d like to see quite a bit more. I want all of our neighborhood schools to be the school of choice. I want parents to come and be eager to send their kids to our schools, and project-based learning will be a part of that.</p>
<p>Baylor: It’s a wonderful way to learn. You’ll get a lot of kids with different ideas and they will work together and collaborate together and that’s just like when they go into the real world and work. That’s a good way for them to get ready to do that.</p>
<p>Sackett: I think project-based learning is a great way for kids to learn 21st century skills that they’re going to need out in the work force. I actually speak nationally around problem and project-based learning in the job that I do, so I believe deeply in project-based learning and I know there is a lot of project-based learning that goes on in our schools and it’s one way that we really need to work on engaging our students.</p>

                <style type="text/css">
                    
                    #td_uid_3_596065265fc82  .td-doubleSlider-2 .td-item1 {
                        background: url(https://i2.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1123-e1499466774263.jpg?resize=80%2C60) 0 0 no-repeat;
                    }
                    #td_uid_3_596065265fc82  .td-doubleSlider-2 .td-item2 {
                        background: url(https://i0.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1119-e1499466782893.jpg?resize=80%2C60) 0 0 no-repeat;
                    }
                    #td_uid_3_596065265fc82  .td-doubleSlider-2 .td-item3 {
                        background: url(https://i0.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1133-e1499466791896.jpg?resize=80%2C60) 0 0 no-repeat;
                    }
                </style>

                <div id="td_uid_3_596065265fc82" class="td-gallery td-slide-on-2-columns">
                    <div class="post_td_gallery">
                        <div class="td-gallery-slide-top">
                           <div class="td-gallery-title"></div>

                            <div class="td-gallery-controls-wrapper">
                                <div class="td-gallery-slide-count"><span class="td-gallery-slide-item-focus">1</span> of 3</div>
                                <div class="td-gallery-slide-prev-next-but">
                                    <i class = "td-icon-left doubleSliderPrevButton"></i>
                                    <i class = "td-icon-right doubleSliderNextButton"></i>
                                </div>
                            </div>
                        </div>

                        <div class = "td-doubleSlider-1 ">
                            <div class = "td-slider">
                                
                    <div class = "td-slide-item td-item1">
                        <figure class="td-slide-galery-figure td-slide-popup-gallery">
                            <a class="slide-gallery-image-link" href="https://i2.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1123-e1499466774263.jpg?fit=300%2C199" title="DSC_1123-e1499466774263"  data-caption="Deborah Kilgore"  data-description="">
                                <img src="https://i2.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1123-e1499466774263.jpg?resize=300%2C199" alt="">
                            </a>
                            <figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Deborah Kilgore</div></figcaption>
                        </figure>
                    </div>
                    <div class = "td-slide-item td-item2">
                        <figure class="td-slide-galery-figure td-slide-popup-gallery">
                            <a class="slide-gallery-image-link" href="https://i0.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1119-e1499466782893.jpg?fit=300%2C199" title="DSC_1119-e1499466782893"  data-caption="Cathy Baylor"  data-description="">
                                <img src="https://i0.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1119-e1499466782893.jpg?resize=300%2C199" alt="">
                            </a>
                            <figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Cathy Baylor</div></figcaption>
                        </figure>
                    </div>
                    <div class = "td-slide-item td-item3">
                        <figure class="td-slide-galery-figure td-slide-popup-gallery">
                            <a class="slide-gallery-image-link" href="https://i0.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1133-e1499466791896.jpg?fit=300%2C239" title="DSC_1133-e1499466791896"  data-caption="Cindy Sackett"  data-description="">
                                <img src="https://i0.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1133-e1499466791896.jpg?resize=300%2C239" alt="">
                            </a>
                            <figcaption class = "td-slide-caption td-gallery-slide-content"><div class = "td-gallery-slide-copywrite">Cindy Sackett</div></figcaption>
                        </figure>
                    </div>
                            </div>
                        </div>

                        <div class = "td-doubleSlider-2">
                            <div class = "td-slider">
                                
                    <div class = "td-button td-item1">
                        <div class = "td-border"></div>
                    </div>
                    <div class = "td-button td-item2">
                        <div class = "td-border"></div>
                    </div>
                    <div class = "td-button td-item3">
                        <div class = "td-border"></div>
                    </div>
                            </div>
                        </div>

                    </div>

                </div>
                
<p>Q: How can the district help its over 600 homeless students and those at risk of homelessness?</p>
<p>Sackett: I think we need to make sure that we are encouraging all of our students to stay in school. I think schools need to be that safe and welcoming environment for them. I think Washington Kids in Transition is a great organization that helps those students as well. It’s really about making sure we’re identifying those families and reaching out to them to get them the help that they need.</p>
<p>Baylor: I think it’s very important to help people in need like this. I have talked to some of the people in the school district who work with homeless students, and they have told me that a lot of people in our community don’t know who to turn to anymore. Their one connection with the government is with the school, so they come to the school for help. We need to keep doing whatever we can. It’s a really sad situation and we need to help.</p>
<p>Kilgore: Schools need to be a safe place. Teachers and staff need training to help students and help students be able to talk to them. It would be nice to have showers, it would be nice to have a place to stash their stuff. There are some particular things we can do within the school. We need more money, we need more staff, we need more training for our teachers and staff to be able to identify, to talk, and we also need a school that is able to be flexible for these children, to help them with their basic needs.</p>
<p>Q: What can you do to help students to be good, well-educated, rounded citizens that learn things like history, the arts and how we relate to each other?</p>
<p>Baylor: I am a strong believer in a liberal arts education for everyone. You’re right, they need to know all of those things. Let’s start with more of (classic literature). A law just passed this year and I don’t know the details exactly but it creates a civics requirement for our students. Isn’t that wonderful? One of the things I also advocate is a good multi-cultural education. Our students need to be prepared to go into the real world. Arts are really important to for me, I am a piano teacher. Arts should be part of the basic education.</p>
<p>Kilgore: I agree that children need a well-rounded education. I am also excited about an additional civics requirement. We have a teacher at Lynnwood Elementary who teaches government all year long in a very authentic way where the kids get together and elect a president and elect other officers and also practice negotiating, practice reaching consensus, making decisions, making laws for their classroom. Those are the kinds of things that sticks with a kid, it sticks for life. Also, a lot of our schools are quite diverse, and that is a really big opportunity right now. Our kids are living and learning, learning to get along with, learning to work conflict out with kids who are very different from them. I think this is a learning lab and these are authentic experiences.</p>
<p>Sackett: I would say we absolutely need to encourage our kids to have the most diverse education that they can. We need to celebrate the fact that we have so many cultures and languages being spoken in our schools. I don’t believe we are on a downtrend by any means of getting rid of any of our electives in our schools. My son at College Place Middle School also created a government and a ruling body and had to work together and it was an experience that he gained great knowledge out of and those are the types of things that go on in this district a lot. We need to encourage all of our teachers and all of our students to engage in those types of activities.</p>
<p>Q: Do you find First Principles useful?</p>
<p>Kilgore: Yes, we need to teach the fundamentals in any subject, but they are better taught and better absorbed as an authentic of a situation as we can make it. Yes, they have to learn math facts, they have to learn times tables, but it is only when they start applying it to real-world problems that it really sticks and they begin to understand those fundamentals. You have to go to a learner where they are.</p>
<p>Baylor: I think that there are certain disciplines that really help mind growth and mind development. People come to me as a piano teacher because I teach them to practice, discipline in their thinking and how to think critically when they come to problems with their playing.</p>
<p>Sackett: I think that we really already do a lot of those things, however, they way in which we teach it might look a little different now. We have to have a base layer in order to create and move beyond that, so I think we have to have that base and build upon that, but doing it in a different way so that we keep kids engaged and they continue to be lifelong learners.</p>
<p>Q: With the exception of budget, what do you think is the most needed improvement to the district?</p>
<p>Baylor: I first moved here 49 years ago and we had a pretty much 99 percent white community. Now, there’s about 50 percent of our students who self-identify as non-white. I think it’s very important that we develop a curriculum that speaks to their experience, so they can see what people like them have contributed to our world.</p>
<p>Kilgore: I do think diversity again is one of our big resources right now that we can leverage off of. But it is something that I think at the elementary level, we’re doing a pretty good job because there are a lot of programs across the district on character education, anti-bullying. One thing I am concerned about is family engagement. Families need to be engaged in developing those skills, learning with the kids, not just getting them engaged when they’re getting punished for bullying, but getting them involved in the front end. How do we communicate?</p>
<p>Sackett: I 100 percent agree with what they just said, but I’m going to take this in a bit of a different way because I think that one of the pieces that we need to be working on are our graduation rates. I think 81 percent is not good enough. We have 19 percent of kids who are not graduating high school in this district and I think part of that is attributed to the equity and inclusion pieces that are lacking in this district. I think one thing we need to work on is making sure we have those electives for kids who are on the bubble who may not engage in the norm of what we consider education to be. We need to celebrate that we are all different learners and that these kids need to be met in so many different areas. They need to know they are seen, they are heard and they are welcome.</p>
<p>Q: What does “diversity” mean to you, and how will you make sure all kids are included when it comes to honor/AP/IB classes?</p>
<p>Sackett: Diversity to me is a very important part. I have a son who is adopted from India, so he does not look like us and we get a lot of “is he with you, who is he with” kinds of things. So to me, diversity is around celebrating our differences. Creating a welcoming environment is the inclusion piece of that. I think it’s hard to remember that kids from all different backgrounds should all have the opportunity to be in any of those advanced learning classes. Really, it’s about making sure our teachers are aware of how to approach and how to talk to all students to make sure they know who they need to speak to when they see a child who may be bored and needs to be in a different classroom or if there’s a student who doesn’t know how to navigate the system.</p>
<p>Baylor: Diversity to me means when I walk up the street, there’s a family across the street that’s Ethiopian. There’s a family next door where the dad is Navajo and the mom is Cambodian. I’m Native American. There’s a Mexican family that lives just down the street and just the other night, they were serenading us with the most beautiful Mariachi music. We need to celebrate that wonderful opportunity to have different points of view, to make you step outside your world and listen to other people. As far as students having more access to programs, I know now, for instance, the IB program, they don’t test all students, so moving to universal testing for advanced programs. My personal issue is that I think the traditional sit down in a classroom and listen to teachers and then you read your book and take a test or write a paper is something that doesn’t work for everybody. I think standards should be kept very high for other types of programs.</p>
<p>Kilgore: As far as diversity, we know children recognize difference when they are two. What we don’t want to do is whitewash difference. We want differences to be celebrated and we want our kids to learn that people are different, that when we come together around our differences we can create something much greater than if we are all the same, so it’s a benefit. I want to address these classes you’re talking about. The first thing I’m going to do is make sure we get bus transportation to any of the programs these kids want to go to. If a kid wants to go to the STEM program at Mountlake Terrace, they should have a bus pass. Right now, they have to get themselves there. If they want to go to the IB program, they have to test “gifted” to go. Kids within the service area get to go, get to try classes. That’s not fair. Just logistically, I would like to make that happen for every child. Secondly, another thing, the AP classes at Lynnwood High School for instance. One of the AP classes didn’t make because they didn’t have 25 kids to take it. Well, if you’re in a school that doesn’t have IB or a magnet for highly capable kids in the traditional sense, maybe you don’t need a 25-kid limit, maybe it’s 15. Maybe you need to have equity. It’s not equal, it’s equity. I also want to talk about testing. I don’t think testing works for every child. When we look at testing, as long as my kids have been in school, we’ve had three standardized tests. One of the ways, it’s not the only way but one of they ways they validate tests is to see if the kids who did well on one test also did well on another test. If you have a kid who doesn’t think in this way, they are not going to do well on this test and we continue to perpetuate this problem. One thing I have heard about is we talk about portfolios. Assessment portfolios, where they can put examples of their work and where they can talk about what did I learn doing this work? And so in that way we can assess, did they learn? Are they a critical thinker? Are they someone who could take this AP class?</p>
<p>In addition, candidates addressed several other questions, including whether schools should make better use of community gardens (candidates agreed they should and noted that some schools already have them) and what can be done to ensure that children with special needs have the best possible education, which candidates acknowledged should be a priority.</p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags td-pb-padding-side">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-pb-padding-side"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing td-with-like">
	            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Fmyedmondsnews.com%2F2017%2F07%2Fcommunity-members-question-school-board-candidates-thursday-event%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-facebook"></div><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Community+members+question+School+Board+candidates+during+Thursday+event&url=http%3A%2F%2Fmyedmondsnews.com%2F2017%2F07%2Fcommunity-members-question-school-board-candidates-thursday-event%2F&via=LynnwoodToday"><div class="td-sp td-sp-twitter"></div><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-googleplus"></div></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/&amp;media=http://myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><div class="td-sp td-sp-pinterest"></div></a>
                <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Community+members+question+School+Board+candidates+during+Thursday+event%20-%20http%3A%2F%2Fmyedmondsnews.com%2F2017%2F07%2Fcommunity-members-question-school-board-candidates-thursday-event%2F" ><div class="td-sp td-sp-whatsapp"></div></a>
                <div class="clearfix"></div>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/" data-text="Community members question School Board candidates during Thursday event" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://myedmondsnews.com/2017/07/local-musician-makes-appearance-famed-waterfront-blues-festival/">Local musician makes an appearance at famed waterfront blues festival</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="http://myedmondsnews.com/2017/07/edmonds-underwater-park-celebrating-40-years-july-8/">Edmonds Underwater Park celebrating 40 years July 8</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="http://myedmondsnews.com/author/teresawippel/">MyEdmondsNews</a></span></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="MyEdmondsNews"></span><meta itemprop="datePublished" content="2017-07-07T17:22:05+00:00"><meta itemprop="dateModified" content="2017-07-07T19:42:51+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://myedmondsnews.com/2017/07/community-members-question-school-board-candidates-thursday-event/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://myedmondsnews.com/wp-content/uploads/2016/02/My-Edmonds-News-Logo-Stacked-013116v2.jpg"></span><meta itemprop="name" content="My Edmonds News"></span><meta itemprop="headline " content="Community members question School Board candidates during Thursday event"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i1.wp.com/myedmondsnews.com/wp-content/uploads/2017/07/DSC_1114.jpg?fit=583%2C386"><meta itemprop="width" content="583"><meta itemprop="height" content="386"></span>        </footer>

    </article> <!-- /.post -->

    
	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/07/community-members-question-school-board-candidates-thursday-event/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://myedmondsnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' />
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
                     </div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='159146' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="42c5f3289e" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="207"/></p>			</form>
			</div><!-- #respond -->
	    </div> <!-- /.content -->
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="td_block_template_1 widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(32637, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','edmonds-schools','election-2017','community-members-question-school-board-candidates-thursday-event']});</script></div></aside><aside class="td_block_template_1 widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(48154, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','edmonds-schools','election-2017','community-members-question-school-board-candidates-thursday-event']});</script></div></aside><aside class="td_block_template_1 widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(1452, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','edmonds-schools','election-2017','community-members-question-school-board-candidates-thursday-event']});</script></div></aside><aside class="td_block_template_1 widget widget_mc4wp_form_widget"><h4 class="block-title"><span>Sign up for the Daily My Edmonds News</span></h4><script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.1.5 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-158268" method="post" data-id="158268" data-name="Newsletter" ><div class="mc4wp-form-fields"><p>
	<label>Email address: </label>
	<input type="email" name="EMAIL" placeholder="Your email address" required />
</p>

<p>
	<input type="submit" value="Sign up" />
</p><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1499489574" /><input type="hidden" name="_mc4wp_form_id" value="158268" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /></div><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"></div>
		</aside><aside class="td_block_template_1 widget bwp-rc-widget"><h4 class="block-title"><span>Recent Comments</span></h4>
		<ul class="bwp-rc-ulist">
<span class="recent-comment-single"><span class="recent-comment-author">Frank Porter</span> on <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/">
Edmonds Kind of 4th on parade (15)</a></br><span class="recent-comment-text">  I agree. What's up carl? – </span> <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/#comment-108384" title="Comment on Edmonds Kind of 4th on parade"><strong>Jul 07, 8:59 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Brian Potter</span> on <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/">
Edmonds Kind of 4th on parade (15)</a></br><span class="recent-comment-text">  Mr. Lovgren- I'm replying here, though many of your concerns to which I will respond were on a different post. (That original post was letter... – </span> <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/#comment-108373" title="Comment on Edmonds Kind of 4th on parade"><strong>Jul 07, 6:31 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Nathaniel Brown</span> on <a href="http://myedmondsnews.com/2017/06/letter-editor-need-smaller-class-sizes-schools/">
Letter to the Editor: We need smaller class sizes in our schools (12)</a></br><span class="recent-comment-text">  Being LGBT is not a "pursuit you choose" any more than being heterosexual is a "pursuit you choose." I'm sorry you had such a bad... – </span> <a href="http://myedmondsnews.com/2017/06/letter-editor-need-smaller-class-sizes-schools/#comment-108365" title="Comment on Letter to the Editor: We need smaller class sizes in our schools"><strong>Jul 07, 5:25 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Nathaniel Brown</span> on <a href="http://myedmondsnews.com/2017/06/letter-editor-need-smaller-class-sizes-schools/">
Letter to the Editor: We need smaller class sizes in our schools (12)</a></br><span class="recent-comment-text">  Thank you!!!!! – </span> <a href="http://myedmondsnews.com/2017/06/letter-editor-need-smaller-class-sizes-schools/#comment-108363" title="Comment on Letter to the Editor: We need smaller class sizes in our schools"><strong>Jul 07, 5:14 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Mike Schindler</span> on <a href="http://myedmondsnews.com/2017/07/letter-editor-voted-approve-tyler-nebeker-edmonds-salary-commission/">
Letter to the editor: Why I voted to approve Tyler Nebeker for Edmonds Salary Commission (6)</a></br><span class="recent-comment-text">  I am of the mindset that he or she who is best qualified, based on what is clearly outlined in a solicitation, regardless of gender,... – </span> <a href="http://myedmondsnews.com/2017/07/letter-editor-voted-approve-tyler-nebeker-edmonds-salary-commission/#comment-108359" title="Comment on Letter to the editor: Why I voted to approve Tyler Nebeker for Edmonds Salary Commission"><strong>Jul 07, 3:49 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Brad Holden</span> on <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/">
Edmonds Kind of 4th on parade (15)</a></br><span class="recent-comment-text">  Looking at photo #7, after reading your post, and was expecting to see something really politically inflammatory or offensive. What I saw was a lady... – </span> <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/#comment-108357" title="Comment on Edmonds Kind of 4th on parade"><strong>Jul 07, 3:27 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">carl lovgren</span> on <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/">
Edmonds Kind of 4th on parade (15)</a></br><span class="recent-comment-text">  As a follow up statement: I thought political views weren't allowed in the parade. You can clearly see a poster in a baby stroller saying... – </span> <a href="http://myedmondsnews.com/2017/07/edmonds-kind-4th-on-parade/#comment-108355" title="Comment on Edmonds Kind of 4th on parade"><strong>Jul 07, 2:51 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Kim Tomczak</span> on <a href="http://myedmondsnews.com/2017/06/edmonds-kind-play-1k-run-parades-fireworks-edmonds-july-4th-made-families/">
Edmonds Kind of Play: From 1k run to parades to fireworks, Edmonds' July 4th made for families (2)</a></br><span class="recent-comment-text">  My household and guests we brought concur. – </span> <a href="http://myedmondsnews.com/2017/06/edmonds-kind-play-1k-run-parades-fireworks-edmonds-july-4th-made-families/#comment-108351" title="Comment on Edmonds Kind of Play: From 1k run to parades to fireworks, Edmonds&#039; July 4th made for families"><strong>Jul 07, 2:08 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Eve Wellington</span> on <a href="http://myedmondsnews.com/2017/07/letter-editor-voted-approve-tyler-nebeker-edmonds-salary-commission/">
Letter to the editor: Why I voted to approve Tyler Nebeker for Edmonds Salary Commission (6)</a></br><span class="recent-comment-text">  Councilmembers Dianne and Adrienne are two of the most discerning, fair and intelligent members on the Council. Thank you for being there! Thank you for... – </span> <a href="http://myedmondsnews.com/2017/07/letter-editor-voted-approve-tyler-nebeker-edmonds-salary-commission/#comment-108349" title="Comment on Letter to the editor: Why I voted to approve Tyler Nebeker for Edmonds Salary Commission"><strong>Jul 07, 1:28 PM</strong></a></span></li></br>
<span class="recent-comment-single"><span class="recent-comment-author">Mark Cornelison</span> on <a href="http://myedmondsnews.com/2017/07/letter-editor-voted-approve-tyler-nebeker-edmonds-salary-commission/">
Letter to the editor: Why I voted to approve Tyler Nebeker for Edmonds Salary Commission (6)</a></br><span class="recent-comment-text">  Having worked in a professional capacity with Mr. Nebeker, I can, with confidence, say that it is a loss to the city. – </span> <a href="http://myedmondsnews.com/2017/07/letter-editor-voted-approve-tyler-nebeker-edmonds-salary-commission/#comment-108347" title="Comment on Letter to the editor: Why I voted to approve Tyler Nebeker for Edmonds Salary Commission"><strong>Jul 07, 12:52 PM</strong></a></span></li></br>
<li class="bwp-rc-ajax-nav">
	<input type="hidden" name="bwp_rc_instance" value="left-front" />
	<input type="hidden" name="bwp_rc_paged" value="1" />
	<input type="hidden" name="bwp_rc_paged_limit" value="10" />
 <a title="View older comments" href="#" class="bwp-rc-older-nav">Older »</a></li>
		</ul>
</aside><aside class="td_block_template_1 widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(1451, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','edmonds-schools','election-2017','community-members-question-school-board-candidates-thursday-event']});</script></div></aside><aside class="td_block_template_1 widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(1450, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','edmonds-schools','election-2017','community-members-question-school-board-candidates-thursday-event']});</script></div></aside><aside class="td_block_template_1 widget bs_multiple_zones"><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script><script type="text/javascript">broadstreet.zone(1452);</script></aside><aside class="td_block_template_1 widget bs_zones"><div><script data-cfasync="false" type="text/javascript">broadstreet.zone(56627, {responsive: true, softKeywords: true, keywords: ['not_home_page','not_landing_page','is_article_page','edmonds-schools','election-2017','community-members-question-school-board-candidates-thursday-event']});</script></div></aside><div class="td_block_wrap td_block_instagram td_block_widget td_uid_5_5960652666b05_rand td_block_template_1"  data-td-block-uid="td_uid_5_5960652666b05" ><div id=td_uid_5_5960652666b05 class="td-instagram-wrap td_block_inner td-pb-margin-side td-column-1"><!-- td instagram source: instagram_cache -->        <!-- header section -->
                    <div class="td-instagram-header">
                <div class="td-instagram-profile-image"><img src="https://scontent.cdninstagram.com/t51.2885-19/926816_311635285669005_334800563_a.jpg"/></div>
                <div class="td-instagram-meta">
                    <div class="td-instagram-user"><a href="https://www.instagram.com/myedmondsnews" target="_blank">@myedmondsnews</a></div>
                    <div class="td-instagram-followers"><span>1,014</span> Followers</div>
                    <a class="td-instagram-button" href="https://www.instagram.com/myedmondsnews" target="_blank">Follow</a>
                    <div class="clearfix"></div>
                </div>
            </div>
            
        <!-- user shared images -->
                    <div class="td-instagram-main td-images-on-row-3">
                                        <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BWPD9o9laec" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/19764846_494860554188369_3428649757919150080_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BWKFmLOFIxD" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/19764589_149275512296197_1398924032887226368_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BWIXSWVlKbU" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/19761663_283958358739959_1856614963632668672_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BVlUuSrFaCn" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/19367571_461425897544289_2337502205289955328_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BVF8vZKgo-H" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/18889308_226382731201624_1229514850397323264_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BUzlea7guZ6" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/18879319_1888869701379947_5453402817060405248_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BUsh2W9gVLS" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/18723006_1522997094440632_3571850929709776896_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BUCxfwzA_St" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/18443722_272199943241413_9035081460872118272_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                            <div class="td-instagram-element">
                            <!-- image -->
                            <a href="https://www.instagram.com/p/BT_ywvIggau" target="_blank">
                                <img class="td-instagram-image" src="https://scontent.cdninstagram.com/t51.2885-15/s640x640/sh0.08/e35/18443406_1908462116088420_978567796851998720_n.jpg"/>
                            </a>
                            <!-- video icon -->
                                                    </div>
                                            <!-- number of images to display -->
                                    <div class="clearfix"></div>
            </div>
            </div></div> <!-- ./block -->                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </div>
    </div> <!-- /.td-container -->

    <!-- Instagram -->
    

    <!-- Footer -->
    <div class="td-footer-container td-container">

	<div class="td-pb-row">
		<div class="td-pb-span12">
					</div>
	</div>

	<div class="td-pb-row">
		<div class="td-pb-span4">
			<div class="td-footer-info td-pb-padding-side"><div class="footer-logo-wrap"><a href="http://myedmondsnews.com/"><img src="http://men.myedmondsnews.netdna-cdn.com/wp-content/uploads/2014/07/logo-banner_65476e62335e430cbf55c727cb855ea9-2.jpg" alt="" title=""/></a></div><div class="footer-text-wrap">An online gathering place for neighbors and friends<div class="footer-email-wrap">Contact us: <a href="mailto:myedmondsnews@gmail.com">myedmondsnews@gmail.com</a></div></div><div class="footer-social-wrap td-social-style2">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/myedmondsnews" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/myedmondsnews" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></div></div><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><a href="http://myedmondsnews.com"><img src="https://i0.wp.com/lynnwoodtoday.com/wp-content/uploads/sites/4/2013/09/MyNNN138.jpg?w=640" data-recalc-dims="1"></a>
<a href="http://authenticallylocal.com/"><img src="https://i1.wp.com/static.tumblr.com/neq6kdr/aR7ll2451/authentic200.png?w=48%25"  data-recalc-dims="1"></a>
</div>
		</aside>		</div>

		<div class="td-pb-span4">
			<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Commenting Policy</span></h4>			<div class="textwidget"><div style="font-size:11px">We welcome comments on all posts at My Edmonds News. To encourage constructive community dialogue, all commenters must use their real names, first and last. Comments from users with names that don't comply with this policy will be removed. We also ask that you comply with our Code of Conduct policy, which you can view <a href="http://myedmondsnews.com/about-2/">here.</a></div></div>
		</aside><aside class="td_block_template_1 widget widget_categories"><h4 class="block-title"><span>Categories</span></h4><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="2337">Category</option>
	<option class="level-0" value="384">Churches</option>
	<option class="level-0" value="2102">Columns</option>
	<option class="level-1" value="2107">&nbsp;&nbsp;&nbsp;Artfully Edmonds</option>
	<option class="level-1" value="2852">&nbsp;&nbsp;&nbsp;Ask the Edmonds Vet</option>
	<option class="level-1" value="2305">&nbsp;&nbsp;&nbsp;Ask the Engineer</option>
	<option class="level-1" value="2341">&nbsp;&nbsp;&nbsp;Beauty of Stone</option>
	<option class="level-1" value="2332">&nbsp;&nbsp;&nbsp;Bird Lore</option>
	<option class="level-1" value="2304">&nbsp;&nbsp;&nbsp;Commendables</option>
	<option class="level-1" value="2570">&nbsp;&nbsp;&nbsp;Day Trip Discoveries</option>
	<option class="level-1" value="1208">&nbsp;&nbsp;&nbsp;Designing Landscapes</option>
	<option class="level-1" value="2105">&nbsp;&nbsp;&nbsp;Edmonds Beauty</option>
	<option class="level-1" value="2108">&nbsp;&nbsp;&nbsp;Edmonds Booktalk</option>
	<option class="level-1" value="2340">&nbsp;&nbsp;&nbsp;Edmonds Fashion</option>
	<option class="level-1" value="2331">&nbsp;&nbsp;&nbsp;Edmonds Fitness Corner</option>
	<option class="level-1" value="2333">&nbsp;&nbsp;&nbsp;Edmonds Healthy Eating</option>
	<option class="level-1" value="1211">&nbsp;&nbsp;&nbsp;Edmonds Kind of Dad</option>
	<option class="level-1" value="2321">&nbsp;&nbsp;&nbsp;Edmonds Kind of Play</option>
	<option class="level-1" value="1241">&nbsp;&nbsp;&nbsp;Edmonds Military Wire</option>
	<option class="level-1" value="2480">&nbsp;&nbsp;&nbsp;Embracing wellness</option>
	<option class="level-1" value="2342">&nbsp;&nbsp;&nbsp;Epic Group Travel Writers</option>
	<option class="level-1" value="2326">&nbsp;&nbsp;&nbsp;Family History</option>
	<option class="level-1" value="2335">&nbsp;&nbsp;&nbsp;Foreign Correspondence</option>
	<option class="level-1" value="2668">&nbsp;&nbsp;&nbsp;Good trees for urban gardens</option>
	<option class="level-1" value="3108">&nbsp;&nbsp;&nbsp;Healthy Lifestyle Tips</option>
	<option class="level-1" value="3114">&nbsp;&nbsp;&nbsp;Looking Back</option>
	<option class="level-1" value="2318">&nbsp;&nbsp;&nbsp;Money Talk</option>
	<option class="level-1" value="2325">&nbsp;&nbsp;&nbsp;My Edmonds Restaurant News</option>
	<option class="level-1" value="2329">&nbsp;&nbsp;&nbsp;Real Housewife</option>
	<option class="level-1" value="2103">&nbsp;&nbsp;&nbsp;Real Talk</option>
	<option class="level-1" value="2109">&nbsp;&nbsp;&nbsp;Recommended Reads</option>
	<option class="level-1" value="2106">&nbsp;&nbsp;&nbsp;Socially Single</option>
	<option class="level-1" value="2324">&nbsp;&nbsp;&nbsp;Tips from the Teacher</option>
	<option class="level-1" value="2950">&nbsp;&nbsp;&nbsp;Traveling Light</option>
	<option class="level-1" value="2104">&nbsp;&nbsp;&nbsp;Travels with Charlize</option>
	<option class="level-0" value="2155">Commentary</option>
	<option class="level-0" value="59">Community Submitted News</option>
	<option class="level-0" value="120">Edmonds Community College</option>
	<option class="level-0" value="696">Edmonds Ferry</option>
	<option class="level-0" value="2479">Edmonds Kind of Idea</option>
	<option class="level-0" value="1614">Edmonds Kind of Neighborhood</option>
	<option class="level-0" value="68">Edmonds Museum</option>
	<option class="level-0" value="921">Election 2010</option>
	<option class="level-0" value="1286">Election 2011</option>
	<option class="level-0" value="1495">Election 2012</option>
	<option class="level-0" value="2090">Election 2013</option>
	<option class="level-0" value="2330">Election 2014</option>
	<option class="level-0" value="2344">Election 2015</option>
	<option class="level-0" value="2830">Election 2016</option>
	<option class="level-0" value="3049">Election 2017</option>
	<option class="level-0" value="117">Entertainment</option>
	<option class="level-1" value="2177">&nbsp;&nbsp;&nbsp;Books</option>
	<option class="level-1" value="2174">&nbsp;&nbsp;&nbsp;Bosatsu</option>
	<option class="level-1" value="2322">&nbsp;&nbsp;&nbsp;Caffeine Kitty</option>
	<option class="level-1" value="2175">&nbsp;&nbsp;&nbsp;Movies</option>
	<option class="level-1" value="155">&nbsp;&nbsp;&nbsp;Restaurants</option>
	<option class="level-1" value="2176">&nbsp;&nbsp;&nbsp;The Arts</option>
	<option class="level-1" value="2319">&nbsp;&nbsp;&nbsp;thrashin&#8217; jack</option>
	<option class="level-0" value="61">Events</option>
	<option class="level-1" value="2002">&nbsp;&nbsp;&nbsp;Event Alert</option>
	<option class="level-0" value="987">Family</option>
	<option class="level-0" value="3">Featured</option>
	<option class="level-0" value="2110">From the Publisher&#8217;s Desk</option>
	<option class="level-0" value="1424">garage sales</option>
	<option class="level-0" value="2667">Government</option>
	<option class="level-1" value="9">&nbsp;&nbsp;&nbsp;City Government</option>
	<option class="level-1" value="2767">&nbsp;&nbsp;&nbsp;County Government</option>
	<option class="level-1" value="2768">&nbsp;&nbsp;&nbsp;Federal Government</option>
	<option class="level-1" value="2766">&nbsp;&nbsp;&nbsp;State Government</option>
	<option class="level-0" value="163">History</option>
	<option class="level-0" value="469">Letters</option>
	<option class="level-0" value="62">Library</option>
	<option class="level-0" value="1266">Milestones</option>
	<option class="level-1" value="1270">&nbsp;&nbsp;&nbsp;Obituaries</option>
	<option class="level-0" value="5">News</option>
	<option class="level-1" value="166">&nbsp;&nbsp;&nbsp;Business</option>
	<option class="level-2" value="548">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Business Spotlight</option>
	<option class="level-2" value="2343">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Sponsor Spotlight</option>
	<option class="level-1" value="11">&nbsp;&nbsp;&nbsp;Education</option>
	<option class="level-1" value="2092">&nbsp;&nbsp;&nbsp;Health and fitness</option>
	<option class="level-1" value="1156">&nbsp;&nbsp;&nbsp;Military News</option>
	<option class="level-1" value="15">&nbsp;&nbsp;&nbsp;Pets</option>
	<option class="level-1" value="732">&nbsp;&nbsp;&nbsp;Politics</option>
	<option class="level-1" value="16">&nbsp;&nbsp;&nbsp;Public Safety</option>
	<option class="level-1" value="14">&nbsp;&nbsp;&nbsp;Traffic</option>
	<option class="level-1" value="1032">&nbsp;&nbsp;&nbsp;Weather</option>
	<option class="level-0" value="2632">Opinion</option>
	<option class="level-0" value="10">People</option>
	<option class="level-0" value="1770">Photos</option>
	<option class="level-0" value="1427">Place</option>
	<option class="level-0" value="144">Port of Edmonds</option>
	<option class="level-0" value="1513">Public Place</option>
	<option class="level-0" value="1278">Real Estate</option>
	<option class="level-0" value="1103">Service Clubs</option>
	<option class="level-0" value="2336">Shop Five Corners</option>
	<option class="level-0" value="12">Shopping</option>
	<option class="level-0" value="103">Showcase</option>
	<option class="level-0" value="1162">Social Services</option>
	<option class="level-0" value="3062">South County Politics</option>
	<option class="level-0" value="13">Sports and Recreation</option>
	<option class="level-1" value="2170">&nbsp;&nbsp;&nbsp;Edmonds CC</option>
	<option class="level-1" value="2173">&nbsp;&nbsp;&nbsp;High School</option>
	<option class="level-1" value="2172">&nbsp;&nbsp;&nbsp;Other Sports</option>
	<option class="level-1" value="2171">&nbsp;&nbsp;&nbsp;SeaWolves</option>
	<option class="level-0" value="17">Sustainability and the Environment</option>
	<option class="level-0" value="2320">This is My Job</option>
	<option class="level-0" value="1364">Transportation</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="2984">Unclassified classified</option>
	<option class="level-0" value="1504">undefined</option>
	<option class="level-0" value="4">Videos</option>
</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			location.href = "http://myedmondsnews.com/?cat=" + dropdown.options[ dropdown.selectedIndex ].value;
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

</aside>		</div>

		<div class="td-pb-span4">
			<aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Our policy on reproducing content</span></h4>			<div class="textwidget"><span xmlns:dct="http://purl.org/dc/terms/" property="dct:title">My Edmonds News</span> by <a xmlns:cc="http://creativecommons.org/ns#" href="http://www.myedmondsnews.com" property="cc:attributionName" rel="cc:attributionURL">http://www.myedmondsnews.com</a> is licensed under a <a rel="license" href="http://creativecommons.org/licenses/by/3.0/">Creative Commons Attribution 3.0 Unported License</a>.</div>
		</aside><aside class="td_block_template_1 widget widget_text"><h4 class="block-title"><span>Submit Community News</span></h4>			<div class="textwidget">Do you have news you'd like to share with the Edmonds community? MyEdmondsNews.com welcomes your contribution.
<a  class="vc_btn vc_btn-darkgrey vc_btn-lg vc_btn_rounded " href="mailto:myedmondsnews@gmail.com" >SUBMIT NEWS</a></div>
		</aside>		</div>
	</div>
</div>

    <!-- Sub Footer -->
            <div class="td-sub-footer-container td-container td-container-border ">
            <div class="td-pb-row">
                <div class="td-pb-span8 td-sub-footer-menu">
                    <div class="td-pb-padding-side">
                        <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-135381" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-135381"><a href="http://myedmondsnews.com/about-2/">About</a>
<ul  class="sub-menu">
	<li id="menu-item-135382" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-135382"><a href="http://myedmondsnews.com/about-2/contact/">Contact</a></li>
</ul>
</li>
<li id="menu-item-135380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-135380"><a href="http://myedmondsnews.com/advertise-2/">Advertise</a>
<ul  class="sub-menu">
	<li id="menu-item-135383" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-135383"><a href="http://myedmondsnews.com/advertise/advertising-options-capture-readers-attention/">Advertising options that capture readers&#8217; attention</a></li>
</ul>
</li>
<li id="menu-item-135384" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-135384"><a href="http://myedmondsnews.com/text-alerts/">Text Alerts</a></li>
<li id="menu-item-135386" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-135386"><a href="http://myedmondsnews.com/public-notices-2/">Public Notices</a></li>
<li id="menu-item-135385" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-135385"><a href="http://myedmondsnews.com/men-merchandise/">MEN merchandise</a></li>
<li id="menu-item-135387" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-135387"><a href="http://myedmondsnews.com/w-video-studio/">W Video Studio</a></li>
<li id="menu-item-135388" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-135388"><a href="http://myedmondsnews.com/trafficferry/">Traffic/Ferry</a></li>
<li id="menu-item-135389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-135389"><a href="http://myedmondsnews.com/events/">Events</a>
<ul  class="sub-menu">
	<li id="menu-item-135390" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-135390"><a href="http://myedmondsnews.com/events/community/add">Submit Event</a></li>
</ul>
</li>
<li id="menu-item-135391" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-135391"><a href="http://myedmondsnews.com/edmonds-links/">Links</a></li>
</ul></div>                    </div>
                </div>

                <div class="td-pb-span4 td-sub-footer-copy">
                    <div class="td-pb-padding-side">
                        &copy; Copyright 2016 - MyEdmondsNews                    </div>
                </div>
            </div>
        </div>
        </div><!--close td-outer-container-->
</div><!--close td-outer-wrap-->

<script>broadstreet.watch({})</script>
<style type="text/css">
    #wpfront-notification-bar 
    {
        background: #888888;
        background: -moz-linear-gradient(top, #888888 0%, #000000 100%);
        background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#888888), color-stop(100%,#000000));
        background: -webkit-linear-gradient(top, #888888 0%,#000000 100%);
        background: -o-linear-gradient(top, #888888 0%,#000000 100%);
        background: -ms-linear-gradient(top, #888888 0%,#000000 100%);
        background: linear-gradient(to bottom, #888888 0%, #000000 100%);
        filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#888888', endColorstr='#000000',GradientType=0 );
    }

    #wpfront-notification-bar div.wpfront-message
    {
        color: #ffffff;
    }

    #wpfront-notification-bar a.wpfront-button
    {
        background: #00b7ea;
        background: -moz-linear-gradient(top, #00b7ea 0%, #009ec3 100%);
        background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#00b7ea), color-stop(100%,#009ec3));
        background: -webkit-linear-gradient(top, #00b7ea 0%,#009ec3 100%);
        background: -o-linear-gradient(top, #00b7ea 0%,#009ec3 100%);
        background: -ms-linear-gradient(top, #00b7ea 0%,#009ec3 100%);
        background: linear-gradient(to bottom, #00b7ea 0%, #009ec3 100%);
        filter: progid:DXImageTransform.Microsoft.gradient( startColorstr='#00b7ea', endColorstr='#009ec3',GradientType=0 );

        color: #ffffff;
    }

    #wpfront-notification-bar-open-button
    {
        background-color: #00b7ea;
    }

    #wpfront-notification-bar  div.wpfront-close 
    {
        border: 1px solid #555555;
        background-color: #555555;
        color: #000000;
    }

    #wpfront-notification-bar  div.wpfront-close:hover 
    {
        border: 1px solid #aaaaaa;
        background-color: #aaaaaa;
    }
</style>


<div id="wpfront-notification-bar-spacer"  style="display: none;">
    <div id="wpfront-notification-bar-open-button" class="top wpfront-bottom-shadow"></div>
    <div id="wpfront-notification-bar" class="wpfront-fixed ">
                <table border="0" cellspacing="0" cellpadding="0">
            <tr>
                <td>
                    <div class="wpfront-message">
                        Support MyEdmondsNews.com by becoming a regular subscriber!                     </div>
                    <div>
                                                                                    <a class="wpfront-button" href="http://myedmondsnews.com/support-us-with-a-subscription/"  target="_self" >Subscribe Now</a>
                                                                                                    </div>
                </td>
            </tr>
        </table>
    </div>
</div>


<style type="text/css">
</style>
<script type="text/javascript">if(typeof wpfront_notification_bar == "function") wpfront_notification_bar({"position":1,"height":0,"fixed_position":"on","animate_delay":0.5,"close_button":false,"button_action_close_bar":false,"auto_close_after":0,"display_after":0,"is_admin_bar_showing":false,"display_open_button":false,"keep_closed":false,"keep_closed_for":0,"position_offset":0,"display_scroll":false,"display_scroll_offset":100});</script>		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		

    <!--

        Theme: Newsmag by tagDiv.com 2017
        Version: 3.4 (rara)
        Deploy mode: deploy
        
        uid: 596065267189a
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
#tribe-events {
    pointer-events: auto !important;
cursor: default;
}

#tribe-events-content.tribe-events-list {
background-color: white;
}

#tribe-events-content.tribe-events-single {
  background-color: white;
}

.broadstreet-countdown-until {
  font-size: 18px;
}

.recent-comment-single {
    margin-left: 0px;
}

.sf-menu > li > a {

    font-size: 11px;
    line-height: 35px;
}

.td-module-meta-info .td-post-date {
    display:none;
}

.td-module-comments a {
    display: none;
}

.td_module_8 .meta-info {
    display: none !important;
}

.td_module_8 .item-details {
    border-bottom: 1px solid #c9c9c9;
}

.td-page-content blockquote p, .td-post-content blockquote p, .mce-content-body blockquote p, .comment-content blockquote p {
    font-size: 20px;
    line-height: 30px;
    text-align: inherit;
    text-transform: none;
}

#bs476134 .bs-youtube-wrap iframe {
    height: 100% !important;
}

.bs-youtube-wrap iframe {
    height: 100% !important;
}

.page-id-132459 aside.widget.bs_zones {
    display:none;
}

.page-id-132459 .td-header-sp-ads {
    display:none;
}

.page-id-132459 aside.widget.bs_multiple_zones {
    display:none;
}

.page-id-148188 .td-a-rec-id-header {
    display:none;
}

a {
    color: #4db2ec;
}

/* 
#td-outer-wrap {
pointer-events: none;
}
.td-header-container, .td-container {
pointer-events: auto !important;
cursor: default;
} */
</style>

<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201727'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/themes/Newsmag/js/tagdiv_theme.js?ver=3.4'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/comment-reply.min.js?ver=6938b1e34e881dc1f3c1c517189a0b1e'></script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-includes/js/wp-embed.min.js?ver=6938b1e34e881dc1f3c1c517189a0b1e'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.1.5'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='http://myedmondsnews.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.1.5'></script>
<![endif]-->

<!-- JS generated by theme -->

<script>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</script>

<script type='text/javascript' src='https://stats.wp.com/e-201727.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.1',blog:'10265272',post:'159146',tz:'-7',srv:'myedmondsnews.com'} ]);
	_stq.push([ 'clickTrackerInit', '10265272', '159146' ]);
</script>

</body>
</html>