<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<meta name="mobile-web-app-capable" content="yes">
	<meta name="apple-mobile-web-app-capable" content="yes">
	<meta name="apple-mobile-web-app-title"
	      content="My Edmonds News - An online gathering place for neighbors and friends">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://myedmondsnews.com/xmlrpc.php">

	
	<!-- This site is optimized with the Yoast SEO plugin v14.6 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>HIgh school sports roundup for June 7, 2021 - My Edmonds News</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://myedmondsnews.com/2021/06/high-school-sports-roundup-for-june-7-2021/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="HIgh school sports roundup for June 7, 2021" />
	<meta property="og:description" content="Girls Basketball Edmonds-Woodway defeated Shorewood 44-37 Edmonds-Woodway scorers: Kaddy Kongira 10, Halle Waram 10, Hazel Mills 8, Nya Deng 5, Melia Plumis 4, Melanie Walsh 4, Sofia Chamorro 3 Shorewood scorers: Symone Pease 18, Addison Trull 9, Kate Evans 2, Joy Brandenstein 3, Izze Peijs 3, Mia Battle 2 Records: Edmonds-Woodway 4-5; Shorewood 4-5 Edmonds-Woodway next game:..." />
	<meta property="og:url" content="https://myedmondsnews.com/2021/06/high-school-sports-roundup-for-june-7-2021/" />
	<meta property="og:site_name" content="My Edmonds News" />
	<meta property="article:publisher" content="https://www.facebook.com/myedmondsnews" />
	<meta property="article:published_time" content="2021-06-09T03:43:35+00:00" />
	<meta property="article:modified_time" content="2021-06-09T03:46:40+00:00" />
	<meta property="og:image" content="https://myedmondsnews.com/wp-content/uploads/2019/09/My-Edmonds-socials-share-thumb.jpg" />
	<meta property="og:image:width" content="300" />
	<meta property="og:image:height" content="85" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@myedmondsnews" />
	<meta name="twitter:site" content="@myedmondsnews" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://myedmondsnews.com/#website","url":"https://myedmondsnews.com/","name":"My Edmonds News","description":"An online gathering place for neighbors and friends","potentialAction":[{"@type":"SearchAction","target":"https://myedmondsnews.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://myedmondsnews.com/2021/06/high-school-sports-roundup-for-june-7-2021/#webpage","url":"https://myedmondsnews.com/2021/06/high-school-sports-roundup-for-june-7-2021/","name":"HIgh school sports roundup for June 7, 2021 - My Edmonds News","isPartOf":{"@id":"https://myedmondsnews.com/#website"},"datePublished":"2021-06-09T03:43:35+00:00","dateModified":"2021-06-09T03:46:40+00:00","author":{"@id":"https://myedmondsnews.com/#/schema/person/f91bfd4d7ab90bf0c03b9682c04ae639"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://myedmondsnews.com/2021/06/high-school-sports-roundup-for-june-7-2021/"]}]},{"@type":["Person"],"@id":"https://myedmondsnews.com/#/schema/person/f91bfd4d7ab90bf0c03b9682c04ae639","name":"MyEdmondsNews","image":{"@type":"ImageObject","@id":"https://myedmondsnews.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/cab918c5ec4286235c57e2e5242a9528?s=96&d=mm&r=g","caption":"MyEdmondsNews"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//street-production.s3.amazonaws.com' />
<link rel='dns-prefetch' href='//checkout.stripe.com' />
<link rel='dns-prefetch' href='//maps.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="My Edmonds News &raquo; Feed" href="https://myedmondsnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="My Edmonds News &raquo; Comments Feed" href="https://myedmondsnews.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="My Edmonds News &raquo; iCal Feed" href="https://myedmondsnews.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="My Edmonds News &raquo; HIgh school sports roundup for June 7, 2021 Comments Feed" href="https://myedmondsnews.com/2021/06/high-school-sports-roundup-for-june-7-2021/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/myedmondsnews.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='dashicons-css'  href='https://myedmondsnews.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='https://myedmondsnews.com/wp-content/plugins/wunderground/assets/css/wunderground.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://myedmondsnews.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://myedmondsnews.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://myedmondsnews.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cks_cib_styles-css'  href='https://myedmondsnews.com/wp-content/plugins/commenter-ignore-button/css/cks_cib_style.css' type='text/css' media='all' />
<link rel='stylesheet' id='stcr-font-awesome-css'  href='https://myedmondsnews.com/wp-content/plugins/subscribe-to-comments-reloaded/includes/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://myedmondsnews.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.css' type='text/css' media='all' />
<link rel='stylesheet' id='if-menu-site-css-css'  href='https://myedmondsnews.com/wp-content/plugins/if-menu/assets/if-menu-site.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpcomments-styles-css'  href='https://myedmondsnews.com/wp-content/plugins/wp-comment-fields/plugin.styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpcomments-bootstrap-grid-css'  href='https://myedmondsnews.com/wp-content/plugins/wp-comment-fields/assets/css/bootstrap-grid.css' type='text/css' media='all' />
<link rel='stylesheet' id='toronto-pro-css'  href='https://myedmondsnews.com/wp-content/themes/toronto-pro/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://myedmondsnews.com/wp-content/themes/myedmondsnews-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='themeplate-styles-css'  href='https://myedmondsnews.com/wp-content/themes/myedmondsnews-child/assets/css/theme.css' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://myedmondsnews.com/wp-content/plugins/add-to-any/addtoany.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wdp-frontend-style-css'  href='https://myedmondsnews.com/wp-content/plugins/web-directory-pro-v2/assets/css/frontend.css' type='text/css' media='all' />
<link rel='stylesheet' id='decent-comments-widget-css'  href='https://myedmondsnews.com/wp-content/plugins/decent-comments/css/decent-comments-widget.css' type='text/css' media='all' />
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/jquery/ui/menu.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/dist/vendor/wp-polyfill.min.js'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://myedmondsnews.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://myedmondsnews.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://myedmondsnews.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://myedmondsnews.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/dist/dom-ready.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/dist/a11y.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/jquery/ui/autocomplete.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"43574e3ba5","ajaxurl":"https:\/\/myedmondsnews.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/wunderground/assets/js/widget.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/add-to-any/addtoany.min.js'></script>
<script type='text/javascript' data-cfasync='false' src='//street-production.s3.amazonaws.com/init-2.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/commenter-ignore-button/js/jquery.cookie.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cib_titles = {"unignore_text":"Un-Ignore ","ignore_title":"Ignore","ignore_label":"x","unignore_title":"Un-Ignore","unignore_label":"Un-Ignore","removing":"removing","adding":"adding","from_list":"from Ignore List"};
var cib_options = {"sill":"40","delay":"1000","fadein":"2000","fadeout":"2000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/commenter-ignore-button/js/ignorer.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomments_vars = {"ajaxurl":"https:\/\/myedmondsnews.com\/wp-admin\/admin-ajax.php","plugin_url":"https:\/\/myedmondsnews.com\/wp-content\/plugins\/wp-comment-fields","settings":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/wp-comment-fields/js/script.js'></script>
<script type='text/javascript' src='//maps.google.com/maps/api/js?sensor=false&#038;libraries=geometry%2Cplaces&#038;v=3.22&#038;key=AIzaSyAwDbIlctJjn4c_F3V48PwO1svsRnY77K0&#038;ver=1.0.0'></script>
<link rel='https://api.w.org/' href='https://myedmondsnews.com/wp-json/' />
<link rel='shortlink' href='https://myedmondsnews.com/?p=260669' />
<link rel="alternate" type="application/json+oembed" href="https://myedmondsnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmyedmondsnews.com%2F2021%2F06%2Fhigh-school-sports-roundup-for-june-7-2021%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://myedmondsnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmyedmondsnews.com%2F2021%2F06%2Fhigh-school-sports-roundup-for-june-7-2021%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window, document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '384916382677422');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=384916382677422&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code --><script type="text/javascript">
  window.MemberfulOptions = {
    site: "https://myedmondsnews.memberful.com",
    intercept: [
            "http://myedmondsnews.com/?memberful_endpoint=auth",
            "https://myedmondsnews.com/?memberful_endpoint=auth",
            "http://myedmondsnews.com?memberful_endpoint=auth",
            "https://myedmondsnews.com?memberful_endpoint=auth",
          ],
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); };

    s.addEventListener("load", setup, false);

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();
</script>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://myedmondsnews.com"><link rel="https://theeventscalendar.com/" href="https://myedmondsnews.com/wp-json/tribe/events/v1/" /><link rel="icon" href="https://myedmondsnews.com/wp-content/uploads/2019/09/edmond-favicon.png" sizes="32x32" />
<link rel="icon" href="https://myedmondsnews.com/wp-content/uploads/2019/09/edmond-favicon.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://myedmondsnews.com/wp-content/uploads/2019/09/edmond-favicon.png" />
<meta name="msapplication-TileImage" content="https://myedmondsnews.com/wp-content/uploads/2019/09/edmond-favicon.png" />
		<style type="text/css" id="wp-custom-css">
			.category .page-header .page-title{
	font-size: 40px;
  text-transform: uppercase;
  color: #074d81;
}

@media only screen and (min-width: 960px) {
  .widget:not(.bs_zones){
		width:300px;
		margin-left: auto;
    margin-right: auto;
	}
	
}
.wdp-button{
	  color: #fff !important;
    background: #074d81!important;
    border: none;
}
.site-navigation ul li a{
	padding: 13px;
}

.subscribe-panel .subscribe-form input[type="email"] {
	width:49% !important;
}
.show-street-dialog .container {
    width: inherit;
}		</style>
			<!-- Global site tag (gtag.js) - Google Analytics -->
	<script async src="https://www.googletagmanager.com/gtag/js?id=UA-116386092-1"></script>
	<script>
	  window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());

	  gtag('config', 'UA-116386092-1');
	</script>

</head>

<body class="post-template-default single single-post postid-260669 single-format-standard wp-custom-logo tribe-no-js tribe-theme-parent-toronto-pro tribe-theme-child-myedmondsnews-child group-blog">

<div class="header-top-area">
	<div class="container">
		<div class="row">
			<div class="col-md-10 col-xs-12">
				<div class="top-menu-area">
					<div class="top-nav-item">
						<p>Tuesday, June 8, 2021</p>
					</div>
					<div class="top-nav-item">
						<div class="menu-header-eyebrow-menu-container"><ul id="menu-header-eyebrow-menu" class="menu"><li id="menu-item-205780" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205780"><a href="https://myneighbornewsnetwork.com/">MY NEIGHBORHOOD NEWS NETWORK</a></li>
<li id="menu-item-205781" class="active-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-205781"><a href="https://myedmondsnews.com/">MY EDMONDS NEWS</a></li>
<li id="menu-item-205782" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205782"><a href="https://mltnews.com/">MLTNEWS</a></li>
<li id="menu-item-205783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205783"><a href="https://lynnwoodtoday.com/">LYNNWOOD TODAY</a></li>
</ul></div>					</div>
				</div>
			</div>
			<div class="col-md-2 col-xs-12">
				<div class="footer-social-icons">
					<a href="https://www.facebook.com/MyEdmondsNews/" target="_blank"><i class="fa fa-facebook"></i></a>
					<a href="https://twitter.com/myedmondsnews" target="_blank"><i class="fa fa-twitter"></i></a>
					<a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
				</div>
			</div>
		</div>
	</div>
</div>

<div id="page" class="hfeed site">

	<div class="mobile-membership-btn-area text-center visible-xs">
		<a class="membership-btn" href="https://myedmondsnews.com/membership/">Become A Supporter</a>
	</div>

			<div class="top-add-module text-center">
			<div class="container">
				<div class="row">
					<div class="col-md-12">
						<div id="bs_zones-58" class="bs_zones"><div><broadstreet-zone zone-id="1449" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></div><div id="bs_zones-66" class="bs_zones"><div><broadstreet-zone zone-id="78459" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></div>					</div>
				</div>
			</div>
		</div>
	
	<!-- ******************* navigation area ******************* -->
	<div class="wrapper-fluid wrapper-navbar" id="wrapper-navbar">

		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		<div class="header-area hidden-xs hidden-sm">
			<div class="container">
				<div class="row">
					<div class="col-md-12">

						<div class="header-logo-area">
							<a class="navbar-brand" href="https://myedmondsnews.com/"
							   title="My Edmonds News" rel="home">
								<img src="https://dpa730eaqha29.cloudfront.net/myedmondsnews/wp-content/uploads/2019/10/My-Edmonds-News-Logo1.png"
								     srcset="https://dpa730eaqha29.cloudfront.net/myedmondsnews/wp-content/uploads/2019/10/My-Edmonds-News-Logo1.png 1x, https://dpa730eaqha29.cloudfront.net/myedmondsnews/wp-content/uploads/2019/10/My-Edmonds-News-Logo1.png 2x"
								     alt="My Edmonds News">
							</a>
							<span class="site-tagline hidden-xs">An online gathering place for neighbors and friends</span>
						</div>

						<div class="header-search-box pull-right">
							<a href="#"><i class="fa fa-search"></i></a>
							<form method="get" action="https://myedmondsnews.com" class="header-search-form" role="search">
								<input name="s" id="search-input" class="search-field form-control" placeholder="Search" required="" value="" type="search" autofocus>
								<button type="submit"><i class="fa fa-search"></i></button>
								<input type="hidden" name="post_type" value="post">
							</form>
						</div>

						<div class="header-sub-menu-area pull-right">
							<!-- The WordPress Menu goes here -->
							<div class="menu-top-menu-container"><ul id="sub-menu" class="menu"><li id="menu-item-205578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-205578"><a href="https://myedmondsnews.com/about-2/">About <i class="fa fa-angle-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-205588" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205588"><a href="https://myedmondsnews.com/w-video-studio/">W Video Studio</a></li>
	<li id="menu-item-205586" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205586"><a href="https://myedmondsnews.com/newsletters/">Newsletters</a></li>
</ul>
</li>
<li id="menu-item-205760" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-205760"><a href="https://myedmondsnews.com/advertise-2/">Advertise <i class="fa fa-angle-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-230416" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-230416"><a href="https://myedmondsnews.com/we-love-our-advertisers/">We Love Our Advertisers</a></li>
</ul>
</li>
<li id="menu-item-205664" class="mydmonds-support-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-205664"><a href="https://myedmondsnews.com/membership/">Support Us</a></li>
</ul></div>						</div>

					</div>
				</div>
			</div>
		</div>

		<nav class="site-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">

			<div class="navbar">

				<div class="container">

					<div class="row">

						<div class="col-md-12">

							<div class="navbar-header">

								<!-- .navbar-toggle is used as the toggle for collapsed navbar content -->
								<button type="button" class="navbar-toggle" data-toggle="collapse"
								        data-target=".navbar-responsive-collapse">
									<span class="sr-only">Toggle navigation</span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
									<span class="icon-bar"></span>
								</button>

								<!-- Your site title as branding in the menu -->
								<a class="navbar-brand hidden-md hidden-lg" href="https://myedmondsnews.com/" title="My Edmonds News" rel="home">
									<img src="https://dpa730eaqha29.cloudfront.net/myedmondsnews/wp-content/uploads/2019/10/My-Edmonds-News-Logo1.png"
										 srcset="https://dpa730eaqha29.cloudfront.net/myedmondsnews/wp-content/uploads/2019/10/My-Edmonds-News-Logo1.png 1x, https://dpa730eaqha29.cloudfront.net/myedmondsnews/wp-content/uploads/2019/10/My-Edmonds-News-Logo1.png 2x" alt="My Edmonds News">
								</a>
								<span class="site-tagline-mobile">Powered by My Edmonds News</span>

							</div>

							<!-- The WordPress Menu goes here -->
							<div class="collapse navbar-collapse navbar-responsive-collapse pull-left"><ul id="main-menu" class="nav navbar-nav"><li id="menu-item-224008" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-224008"><a title="COVID-19" href="https://myedmondsnews.com/category/news/health-and-fitness/covid-19-coronavirus/">COVID-19</a></li>
<li id="menu-item-205753" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-205753"><a title="Obituaries" href="https://myedmondsnews.com/obituaries/">Obituaries</a></li>
<li id="menu-item-184012" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-184012"><a title="Eat / Play / Live" href="https://myedmondsnews.com/eat-live-play/">Eat / Play / Live</a></li>
<li id="menu-item-205731" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children nav-item menu-item-205731 dropdown"><a title="Events" href="/events/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Events <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-67878" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-67878"><a title="Submit Event" href="/events/community/add">Submit Event</a></li>
</ul>
</li>
<li id="menu-item-189451" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-189451"><a title="Health &#038; Fitness" href="https://myedmondsnews.com/health-fitness/">Health &#038; Fitness</a></li>
<li id="menu-item-184013" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-184013"><a title="Home &#038; Real Estate" href="https://myedmondsnews.com/home-real-estate/">Home &#038; Real Estate</a></li>
<li id="menu-item-205754" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-205754"><a title="Sound Silver Living" href="https://myedmondsnews.com/sound-silver-living/">Sound Silver Living</a></li>
<li id="menu-item-241542" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-241542"><a title="Weather" href="https://myedmondsnews.com/weather/">Weather</a></li>
<li id="menu-item-245318" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-245318"><a title="Restaurants" href="https://myedmondsnews.com/restaurants/">Restaurants</a></li>
<li class="pc-search-for-mobile"><form method="get" action="https://myedmondsnews.com" class="header-search-form" role="search"><input name="s" id="search-input" class="search-field form-control" placeholder="Search" required="" value="" type="search" autofocus><button type="submit"><i class="fa fa-search"></i></button><input type="hidden" name="post_type" value="post"></form></li></ul></div>
						</div> <!-- .col-md-11 or col-md-12 end -->

					</div> <!-- .row end -->

				</div> <!-- .container -->

			</div><!-- .navbar -->

		</nav><!-- .site-navigation -->
				<nav class="trnto-secondary-menu visible-lg-block visible-md-block">
			<div class="container">
				<div class="row">
					<div class="col-md-12">
						<div class="menu-secondary-menu-container"><ul id="secondary-menu" class="nav navbar-nav"><li id="menu-item-205757" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children nav-item menu-item-205757 dropdown"><a title="Columns" href="https://myedmondsnews.com/category/columns/" data-toggle="dropdown" class="dropdown-toggle" aria-haspopup="true">Columns <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-240502" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-240502"><a title="Art Beat" href="https://myedmondsnews.com/category/columns/art-beat/">Art Beat</a></li>
	<li id="menu-item-212015" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212015"><a title="Bird Lore" href="https://myedmondsnews.com/category/columns/bird-lore/">Bird Lore</a></li>
	<li id="menu-item-212016" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212016"><a title="Day Trip Discoveries" href="https://myedmondsnews.com/category/columns/day-trip-discoveries/">Day Trip Discoveries</a></li>
	<li id="menu-item-212017" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212017"><a title="Edmonds Booktalk" href="https://myedmondsnews.com/category/columns/edmonds-booktalk/">Edmonds Booktalk</a></li>
	<li id="menu-item-212019" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212019"><a title="Edmonds Kind of Play" href="https://myedmondsnews.com/category/columns/edmonds-kind-of-play/">Edmonds Kind of Play</a></li>
	<li id="menu-item-212022" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212022"><a title="Epic Group Travel Writers" href="https://myedmondsnews.com/category/columns/epic-group-travel-writers/">Epic Group Travel Writers</a></li>
	<li id="menu-item-212023" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212023"><a title="Fitness Corner" href="https://myedmondsnews.com/category/fitness-corner/">Fitness Corner</a></li>
	<li id="menu-item-212024" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212024"><a title="From the Publisher&#039;s Desk" href="https://myedmondsnews.com/category/columns/from-the-publishers-desk/">From the Publisher&#8217;s Desk</a></li>
	<li id="menu-item-212025" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212025"><a title="Good trees for urban gardens" href="https://myedmondsnews.com/category/columns/good-trees-for-urban-gardens/">Good trees for urban gardens</a></li>
	<li id="menu-item-212026" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212026"><a title="Healthy Eating" href="https://myedmondsnews.com/category/news/health-and-fitness/healthy-eating/">Healthy Eating</a></li>
	<li id="menu-item-212027" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-212027"><a title="Just Around the Corner" href="https://myedmondsnews.com/category/just-around-the-corner-columns/">Just Around the Corner</a></li>
	<li id="menu-item-212028" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212028"><a title="Kids are Bookin&#039; It" href="https://myedmondsnews.com/category/kids-are-bookin-it/">Kids are Bookin&#8217; It</a></li>
	<li id="menu-item-212031" class="menu-item menu-item-type-custom menu-item-object-custom nav-item menu-item-212031"><a title="Life Thank You for Having Me" href="https://myedmondsnews.com/category/columns/life/">Life Thank You for Having Me</a></li>
	<li id="menu-item-212032" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212032"><a title="Looking Back" href="https://myedmondsnews.com/category/columns/looking-back/">Looking Back</a></li>
	<li id="menu-item-240504" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-240504"><a title="Poet&#039;s Corner" href="https://myedmondsnews.com/category/edmonds-entertainment/poets-corner/">Poet&#8217;s Corner</a></li>
	<li id="menu-item-212033" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212033"><a title="Recommended Reads" href="https://myedmondsnews.com/category/columns/recommended-reads/">Recommended Reads</a></li>
	<li id="menu-item-240505" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-240505"><a title="Restaurant News" href="https://myedmondsnews.com/category/restaurant-news/">Restaurant News</a></li>
	<li id="menu-item-212035" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-212035"><a title="Travelogue" href="https://myedmondsnews.com/category/columns/travelogue/">Travelogue</a></li>
	<li id="menu-item-240503" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-240503"><a title="Under the Weather" href="https://myedmondsnews.com/category/under-the-weather/">Under the Weather</a></li>
	<li id="menu-item-249621" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-249621"><a title="The Writer&#039;s Desk" href="https://myedmondsnews.com/category/the-writers-desk/">The Writer&#8217;s Desk</a></li>
</ul>
</li>
<li id="menu-item-205690" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-205690"><a title="Photos" href="https://myedmondsnews.com/category/photos/">Photos</a></li>
<li id="menu-item-205691" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-205691"><a title="Public Safety" href="https://myedmondsnews.com/category/news/public-safety/">Public Safety</a></li>
<li id="menu-item-205758" class="menu-item menu-item-type-taxonomy menu-item-object-category nav-item menu-item-205758"><a title="Schools" href="https://myedmondsnews.com/category/schools/">Schools</a></li>
<li id="menu-item-205693" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent nav-item menu-item-205693"><a title="Sports" href="https://myedmondsnews.com/category/sports/">Sports</a></li>
<li id="menu-item-205759" class="menu-item menu-item-type-post_type menu-item-object-page nav-item menu-item-205759"><a title="Marketing Services" href="https://myedmondsnews.com/business-resources-from-kaufer-dmc/">Marketing Services</a></li>
</ul></div>					</div>
				</div>
			</div>
		</nav>
		
		
	</div><!-- .wrapper-navbar end -->

<div class="wrapper" id="single-wrapper">

    <div id="content" class="container">

        <div class="row">

            <div id="primary"
                 class="col-md-8 content-area">

                <main id="main" class="site-main" role="main">

					
						
<article id="post-260669" class="post-260669 post type-post status-publish format-standard hentry category-high-school-sports-2 category-sports">

	
	<header class="entry-header">
		<h2 class="entry-title">HIgh school sports roundup for June 7, 2021</h2>
		
		<div class="entry-meta">
			
			<span class="posted-on">Posted: June 8, 2021 </span><span class="post-views"><i class="fa fa-eye"></i> 3 </span>		</div>

	</header><!-- .entry-header -->

	<div class="entry-content">
		<h3>Girls Basketball</h3>
<p><strong>Edmonds-Woodway defeated Shorewood 44-37</strong></p>
<p>Edmonds-Woodway scorers: Kaddy Kongira 10, Halle Waram 10, Hazel Mills 8, Nya Deng 5, Melia Plumis 4, Melanie Walsh 4, Sofia Chamorro 3</p>
<p>Shorewood scorers: Symone Pease 18, Addison Trull 9, Kate Evans 2, Joy Brandenstein 3, Izze Peijs 3, Mia Battle 2</p>
<p>Records: Edmonds-Woodway 4-5; Shorewood 4-5</p>
<p>Edmonds-Woodway next game: at Shorecrest; Wednesday June 9; 7:15 p.m.</p>
<p><strong>Meadowdale defeated Lynnwood 66-53</strong></p>
<p>Meadowdale scorers: Fatoumata Jaiteh 17, Jordan Leith 17, Gia Powell 16, Kaisha Stark 9, Ava Powell 3, Jenaly Gabriel 2, McKenna Kuecker 2,</p>
<p>Lynnwood scorers: Nyree Johnson 19, Kayla Lorenz 14, Aniya Hooker 9, Dina Yonas 6, Mataya Canada 3, Sarah McArthur 2</p>
<p>Records: Meadowdale 5-3; Edmonds-Woodway 4-5</p>
<p>Meadowdale next game: vs Shorewood; Wednesday June 9; 7:15 p.m. at Meadowdale High School</p>
<p>Lynnwood next game: at Kamiak; Wednesday June 9; 7:15 p.m.</p>
<p><strong>Kamiak defeated Mountlake Terrace 68-28</strong></p>
<p>Records: Kamiak 6-3; Mountlake Terrace 6-2</p>
<p>Mountlake Terrace next game: vs Cedarcrest; Wednesday June 9; 5:40 p.m.</p>
<h3>Boys Wrestling</h3>
<p><strong>Lynnwood defeated Mariner 66-6</strong></p>
<p>Records: Lynnwood 3-6; Mariner 0-8</p>
<p>Lynnwood next match: vs Kamiak; Wednesday June 9; 7 p.m. at Lynnwood High School</p>
<p><strong>Edmonds-Woodway defeated Cedarcrest 48-21</strong></p>
<p>106- Double forfeit; 113- AP Tran (EW) won by forfeit; 120- Miguel Tamayo (CC) won by forfeit; 126; Double forfeit; 132- Baylor Dekinger (EW) pinned Jarod Linerude (CC); 138- Jacob Pahre (EW) defeated Franciso Contreras (CC) 4-0; 145- Reece LeCompte (EW) won by forfeit; 152- Evan Reid (CC) pinned George Quitans (EW); 160- Brendan Baldock (EW) won by forfeit; 170- Liam Fitting (EW) won by forfeit; 182- Ryan McPhee (CC) defeated Justus Whittaker (EW) by decision; 195- Alex Rapelje (EW) pinned Tony Weiker (CC); 220- Reed Burmaster (EW) won by forfeit; 285- Matthew Weinert (CC) pinned Evan Gibbs (EW)</p>
<p>Records: Edmonds-Woodway 7-2; Cedarcrest 5-3</p>
<p>Edmonds-Woodway next match: vs Shorecrest; Wednesday June 9; 7 p.m. at Edmonds-Woodway High School</p>
<p><strong>Shorecrest defeated Meadowdale 35-34</strong></p>
<p>No details reported</p>
<p>Records: Shorecrest 4-4; Meadowdale 5-3</p>
<p>Meadowdale next match: at Shorewood; Wednesday June 9; 7 p.m.</p>
<p><em>&#8212; Compiled by Steve Willits</em></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://myedmondsnews.com/2021/06/high-school-sports-roundup-for-june-7-2021/" data-a2a-title="HIgh school sports roundup for June 7, 2021"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fmyedmondsnews.com%2F2021%2F06%2Fhigh-school-sports-roundup-for-june-7-2021%2F&amp;linkname=HIgh%20school%20sports%20roundup%20for%20June%207%2C%202021" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fmyedmondsnews.com%2F2021%2F06%2Fhigh-school-sports-roundup-for-june-7-2021%2F&amp;linkname=HIgh%20school%20sports%20roundup%20for%20June%207%2C%202021" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fmyedmondsnews.com%2F2021%2F06%2Fhigh-school-sports-roundup-for-june-7-2021%2F&amp;linkname=HIgh%20school%20sports%20roundup%20for%20June%207%2C%202021" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_linkedin" href="https://www.addtoany.com/add_to/linkedin?linkurl=https%3A%2F%2Fmyedmondsnews.com%2F2021%2F06%2Fhigh-school-sports-roundup-for-june-7-2021%2F&amp;linkname=HIgh%20school%20sports%20roundup%20for%20June%207%2C%202021" title="LinkedIn" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>	</div><!-- .entry-content -->

	<footer class="entry-footer"></footer><!-- .entry-footer -->

	
</article><!-- #post-## -->


													
<div id="comments" class="comments-area comments">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/06/high-school-sports-roundup-for-june-7-2021/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://myedmondsnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><div class="form-group comment-form-comment">
    <label for="comment">Comment <span class="required">*</span></label>
    <textarea class="form-control" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
    </div><div class="form-group comment-form-author"><label for="author">Name <span class="required">* (First and last required)</span></label> <input class="form-control" id="author" name="author" type="text" value="" size="30" aria-required='true' /></div>
<div class="form-group comment-form-email"><label for="email">Email <span class="required">*</span></label> <input class="form-control" id="email" name="email" type="email" value="" size="30" aria-required='true' /></div>
<div class="form-group comment-form-address"><label for="address">City/State of Residence <span class="required">*</span></label> <input class="form-control" id="address" name="address" type="text" value="" size="30" aria-required='true' /></div>
<div class="form-group comment-form-url"><label for="url">Website</label> <input class="form-control" id="url" name="url" type="url" value="" size="30" /></div>
<p class='comment-form-subscriptions'><label for='subscribe-reloaded'><input style='width:30px' type='checkbox' name='subscribe-reloaded' id='subscribe-reloaded' value='yes' /> Notify me of followup comments via e-mail. You can also <a href="https://myedmondsnews.com/comment-subscriptions/?srp=260669&amp;srk=962e8450b1d7d0116bd26da1224614ef&amp;sra=s&amp;srsrc=f">subscribe</a> without commenting.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-default" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='260669' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c7a739f2fa" /></p><input type="hidden" id="ak_js" name="ak_js" value="13"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	    <p style="color: green; font-weight: bold;">
        Real first and last names — as well as city of residence — are required for all commenters.
        <br /> This is so we can verify your identify before approving your comment.
    </p>

</div><!-- #comments -->
						                        <!-- add subscribe from -->
						<div class="subscribe-panel">

	<h3 class="subscribe-heading">My Edmonds News</h3>
	<p>Sign Up for Our Daily Edmonds Newsletter</p>

	<script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.8.4 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-158268 mc4wp-form-theme mc4wp-form-theme-red mc4wp-ajax" method="post" data-id="158268" data-name="Newsletter" ><div class="mc4wp-form-fields"><div class="subscribe-form torontopro-mailchimp-form">
    <input type="email" name="EMAIL" placeholder="Enter your email address" style="width:60% !important;margin-bottom:10px !important" required />
    <script src="https://www.google.com/recaptcha/api.js" async defer></script>
	<div class="g-recaptcha" data-sitekey="6LeL930UAAAAADYqKapnDDA3PYjy1BfUlNbH13Nw"></div>
  	<input type="submit" value="Sign Up" style="width:60%;margin-top:10px" />
</div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1623210407" /><input type="hidden" name="_mc4wp_form_id" value="158268" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin -->
</div>

<!--                        <section class="related-posts-area">-->
                            <!-- <h4 class="related-posts-area-heading">-->
							<!--</h4>-->

							
<!--                            <div class="trnto-next-post-nav" data-id="--><!--"></div>-->

<!--                        </section>-->

					
                    <div class="back-to-home text-center">
                        <a href="https://myedmondsnews.com">BACK TO HOME</a>
                    </div>

                </main><!-- #main -->

            </div><!-- #primary -->

            <div id="secondary" class="col-md-4 widget-area hidden-xs hidden-sm single-post-sidebar"
                 role="complementary">

				<aside id="bs_zones-82" class="widget bs_zones"><div><broadstreet-zone zone-id="83030" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-39" class="widget bs_zones"><div><broadstreet-zone zone-id="32637" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-36" class="widget bs_zones"><div><broadstreet-zone zone-id="48154" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-65" class="widget bs_zones"><div><broadstreet-zone zone-id="76025" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-50" class="widget bs_zones"><div><broadstreet-zone zone-id="59357" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="decent_comments_widget-4" class="widget widget_decent_comments_widget"><h3 class="widget-title">Recent Comments</h3><div class="decent-comments"><ul><li><div class="comment"><span class="comment-author">MyEdmondsNews</span><span class="comment-link"> on <a href="https://myedmondsnews.com/2021/06/edmonds-city-council-candidates-build-their-war-chests-as-campaign-activity-ramps-up/#comment-316971">Edmonds City Council candidates build their war chests as campaign activity ramps up</a></span><span class="comment-excerpt">Yes - thanks. Will fix. </span></div></li><li><div class="comment"><span class="comment-author">Michelle Dotsch</span><span class="comment-link"> on <a href="https://myedmondsnews.com/2021/06/edmonds-city-council-candidates-build-their-war-chests-as-campaign-activity-ramps-up/#comment-316970">Edmonds City Council candidates build their war chests as campaign activity ramps up</a></span><span class="comment-excerpt">I believe the correct date of....</span></div></li><li><div class="comment"><span class="comment-author">Carol Riddell</span><span class="comment-link"> on <a href="https://myedmondsnews.com/2021/06/bird-lore-white-rumped-sandpiper/#comment-316965">Bird Lore: White-rumped Sandpiper</a></span><span class="comment-excerpt">Thank you all for taking the....</span></div></li><li><div class="comment"><span class="comment-author">Julia Wiese</span><span class="comment-link"> on <a href="https://myedmondsnews.com/2021/06/scene-in-edmonds-lions-mane-jellyfish/#comment-316947">Scene in Edmonds: Lion&#8217;s mane jellyfish</a></span><span class="comment-excerpt">Cool shot Doug! </span></div></li><li><div class="comment"><span class="comment-author">Shannon Lebesis</span><span class="comment-link"> on <a href="https://myedmondsnews.com/2021/06/bird-lore-white-rumped-sandpiper/#comment-316935">Bird Lore: White-rumped Sandpiper</a></span><span class="comment-excerpt">Great info. He was in my....</span></div></li></ul></div></aside><aside id="text-64" class="widget widget_text">			<div class="textwidget"><p><a href="http://myedmondsnews.com/comments/">More recent comments</a></p>
</div>
		</aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="mobile_ads">
	<div id="mobile_ad_1">
		
	</div>
	<div id="mobile_ad_2">
		
	</div>
	<div id="mobile_ad_3">
		
	</div>
</div></div></aside><aside id="bs_zones-38" class="widget bs_zones"><div><broadstreet-zone zone-id="48154" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-34" class="widget bs_zones"><div><broadstreet-zone zone-id="1450" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-79" class="widget bs_zones"><div><broadstreet-zone zone-id="84491" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-40" class="widget bs_zones"><div><broadstreet-zone zone-id="56627" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside><aside id="bs_zones-51" class="widget bs_zones"><div><broadstreet-zone zone-id="63713" keywords="not_home_page,not_landing_page,is_article_page,high-school-sports-2,recreation,sports,high-school-sports-roundup-for-june-7-2021,post" soft-keywords="true"></broadstreet-zone></div></aside>
            </div>

        </div><!-- .row -->

    </div><!-- Container end -->

</div><!-- Wrapper end -->


<div class="wrapper footer-area" id="wrapper-footer">

	<div class="footer-top-area">

		<div class="container">
			<div class="row">

				<div class="col-md-8 col-xs-12">
					<div class="footer-menu-area">
						<div class="menu-footer-menu-container"><ul id="footer-menu" class="menu"><li id="menu-item-205702" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205702"><a href="https://myedmondsnews.com/commenting-policy/">Commenting Policy</a></li>
<li id="menu-item-205701" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-205701"><a href="https://myedmondsnews.com/our-policy-on-reproducing-content/">Our policy on reproducing content</a></li>
<li id="menu-item-205703" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-205703"><a href="mailto:myedmondsnews@gmail.com">Submit News</a></li>
</ul></div>					</div>
				</div>

				<div class="col-md-4 col-xs-12">
					<div class="footer-social-icons">
						<a href="https://www.facebook.com/MyEdmondsNews/" target="_blank"><i class="fa fa-facebook"></i></a>
						<a href="https://twitter.com/myedmondsnews" target="_blank"><i class="fa fa-twitter"></i></a>
						<a href="https://www.youtube.com/channel/UCFFyxTO0wQVeKBKuRhlWJiw" target="_blank"><i class="fa fa-youtube"></i></a>
					</div>
				</div>

			</div>
		</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">

		<div class="container">
			<div class="row">

				<div class="col-md-6 col-xs-12">
					<div class="site-dev-info">
						<p>Website by <a href="https://webpublisherpro.com" target="_new">Web Publisher PRO</a></p>
					</div>
				</div>

				<div class="col-md-6 col-xs-12">
					<div class="site-info text-right">
						<p>&copy; Copyright 2021 | All rights reserved by <a class="site-name" href="https://myedmondsnews.com/" rel="home">My Edmonds News</a></p>
					</div><!-- .site-info -->
				</div>

			</div>
		</div>

	</footer>

	<div class="scroll-up" style="display: block;">
        <i class="fa fa-angle-up"></i>
    </div>

</div><!-- wrapper end -->

</div><!-- #page -->

<script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','high-school-sports-2','recreation','sports','high-school-sports-roundup-for-june-7-2021','post']</script><script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["high-school-sports-2","recreation","sports","high-school-sports-roundup-for-june-7-2021","post"],"url":"high-school-sports-roundup-for-june-7-2021"};</script><script data-cfasync='false'>if (window.broadstreet && window.broadstreet.loadNetworkJS) window.broadstreet.loadNetworkJS(44)</script>		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>        <script>
            var wordLimit = Number('350');

            jQuery(window).load(function () {
                jQuery('.form-group.comment-form-comment').append('<p class="comment_limit">' +
                    'Total: <span id="display_count">0</span> words. Words left: <span id="word_left">' + wordLimit + '</span></p>');
                jQuery('#subscribe-reloaded').attr('checked', 'checked');
                jQuery("#commentform").removeAttr("novalidate");
            });
            jQuery(document).ready(function () {
                jQuery("#comment").on('keyup', function () {
                    var words = this.value.match(/\S+/g).length;
                    if (words > wordLimit) {
                        var trimmed = jQuery(this).val().split(/\s+/, wordLimit).join(" ");
                        jQuery(this).val(trimmed + " ");
                    }
                    else {
                        jQuery('#display_count').text(words);
                        jQuery('#word_left').text(wordLimit - words);
                    }
                });
            });
        </script>
	<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script src='https://myedmondsnews.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/underscore.min.js'></script>
<script src='https://myedmondsnews.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/wp-util.min.js'></script>
<script type='text/javascript'>
var trntoAjaxUrl='https://myedmondsnews.com/wp-admin/admin-ajax.php';
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/themes/toronto-pro/assets/js/theme.min.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='//checkout.stripe.com/v2/checkout.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/sumo/sumoselect.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/web-directory-pro-v2/assets/vendor/maplace/maplace.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wdp_checkout_params = {"key":"","label":"Pay For Claiming","amount":"20000","currency":"usd","name":"My Edmonds News"};
/* ]]> */
</script>
<script type='text/javascript'>
var hideOnMobile = true;
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/web-directory-pro-v2/assets/js/frontend.js'></script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/akismet/_inc/form.js'></script>
<script type='text/javascript' defer src='https://myedmondsnews.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_ajax_vars = {"loading_character":"\u2022","ajax_url":"https:\/\/myedmondsnews.com\/wp-admin\/admin-ajax.php?action=mc4wp-form","error_text":"Oops. Something went wrong. Please try again later."};
/* ]]> */
</script>
<script type='text/javascript' src='https://myedmondsnews.com/wp-content/plugins/mc4wp-premium/ajax-forms/assets/js/ajax-forms.min.js'></script>
	<script>
		jQuery(document).ready(function ($) {
			jQuery('#subscribe-reloaded').prop('checked', false)
		});
	</script>
	
</body>

</html>
